Bug 314341 - [all_langs] untranslated warning message about requiring a non-xen kernel
[all_langs] untranslated warning message about requiring a non-xen kernel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-kdump (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: David Lehman
: Translation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-01 14:21 EDT by David Lehman
Modified: 2008-05-21 13:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0396
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:22:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
system-config-kdump is not fully localized (10.86 KB, image/png)
2008-02-28 19:36 EST, Chester Cheng
no flags Details

  None (edit)
Description David Lehman 2007-10-01 14:21:06 EDT
Description of problem:
Warning message about needing a non-xen kernel is not translated.

Version-Release number of selected component (if applicable):
system-config-kdump-1.0.12-1.el5

How reproducible:
Always in non-english lang.

Steps to Reproduce:
1. run s-c-kdump while a xen kernel is booted
2. observe warning dialog when exiting
3.
  
Actual results:
Message is not translated.

Expected results:
Message is translated.

Additional info:
Comment 2 RHEL Product and Program Management 2007-10-15 23:36:46 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Chester Cheng 2008-02-27 02:32:54 EST
I suspect that the .pot file is required to be updated by developer.
Dave, could you tell us which language did you use?
Comment 7 Chester Cheng 2008-02-27 02:40:45 EST
Confirmed that the .pot file is required to be updated.  See translation
progress at:
http://translate.fedoraproject.org/module/system-config-kdump#HEAD
Comment 8 David Lehman 2008-02-27 11:21:18 EST
There are no changes between the POT file I just generated locally and the one
in CVS, meaning there are no new strings that require translation since the last
update on 13 September 2007.

The only generally up-to-date languages that have not been updated since the
last new strings appeared (on 2007/09/13) are uk, sk, ru, pa, lv, hu, da, zh_TW,
bs. Perhaps we do not need those languages?
Comment 9 Ankit Patel 2008-02-28 02:24:31 EST
Hi Dave,

Can you please provide a screenshot, which is showing in english... So, we could
identify the problem.

Thanks!
Comment 10 David Lehman 2008-02-28 10:59:28 EST
I do not have a screen shot, but here is the relevant entry from the POT file:

#: ../src/system-config-kdump.py:320
#, python-format
msgid ""
"WARNING: xen kdump support requires a non-xen %s RPM to perform actual crash "
"dump capture. Please be sure you have the non-xen %s RPM of the same version "
"as your xen kernel installed."
msgstr ""
Comment 11 Chester Cheng 2008-02-28 19:36:18 EST
Created attachment 296294 [details]
system-config-kdump is not fully localized

Hi, I have a screen shot here.
I download system-config-kdump's po files from two places:
1. http://translate.fedoraproject.org/module/system-config-kdump
2. :ext:cvs.devel.redhat.com:/cvs/dist/rpms/system-config-kdump/

and in both places (I used zh_TW.po for example), the entries of the English
being shown in the screenshot are translated, but not appeared in
system-config-kdump.  Maybe a rebuild will improve this situation?
Comment 12 Ankit Patel 2008-02-29 01:26:14 EST
Hi Dave,

1. We support only 23 languages in house, which are as.po, bn_IN.po, de.po,
es.po, fr.po, gu.po, hi.po, it.po, ja.po, kn.po, ko.po, ml.po, mr.po, or.po,
pa.po, pt_BR.po, ru.po, si.po, ta.po, te.po, ur.po, zh_CN.po, zh_TW.po.
2. Currently only 4 languages out of these are incomplete, which are pa.po,
ru.po, si.po, zh_TW.po (So, we can get them translated anytime you want)
3. Screenshot attached (https://bugzilla.redhat.com/attachment.cgi?id=296294) by
Chester, shows untranslated message, even though it's translated. That means
*Rebuild* of the package is required with all latest translation.
Comment 13 David Lehman 2008-02-29 11:58:21 EST
I found the problem. It is a programming error on my part that is preventing the
strings from getting translated. I have a fix and will check it in to CVS shortly.

Incidentally, the same error was preventing several other warnings from being
displayed in translated form.
Comment 14 Denise Dumas 2008-02-29 13:31:27 EST
Because this is widespread, we'd like to get this in 5.2 as an exception.
Comment 16 David Lehman 2008-03-19 19:47:27 EDT
This is an easy fix. I've verified that the code change is sufficient to enable
display of the existing translated text, so no further effort is necessary on
the part of the translation team other than to verify the fix if they like.

The code change is trivial and can easily be fixed along with the other
s-c-kdump bugs currently slated for 5.2.
Comment 17 David Lehman 2008-03-20 11:54:50 EDT
Fixed in system-config-kdump-1.0.14-1.el5.
Comment 21 errata-xmlrpc 2008-05-21 13:22:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0396.html

Note You need to log in before you can comment on or make changes to this bug.