Bug 314421 - auto-compression-mode in default.el prevents user customization
auto-compression-mode in default.el prevents user customization
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: emacs (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Karel Klíč
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-01 14:31 EDT by Jonathan Peatfield
Modified: 2010-04-14 05:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 10:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 114808 None None None Never

  None (edit)
Description Jonathan Peatfield 2007-10-01 14:31:50 EDT
Description of problem:

In #114808 (a long time ago), the adding of (auto-compression-mode t) to
default.el was done to work round a different problem.

However, default.el is loaded after the user's .emacs so this overrides any
settings they may have added themselves and causes the customization feature for
this setting to *seem* to work but actually be ignored.

Those who use a *different* compression package than the default (e.g. crypt++
rather than jka-comp have to either disable loading of default.el or do some
nasty hacks to cause jka-comp not to be loaded...

Version-Release number of selected component (if applicable):

All since 21.3-12 according to the rpm changelog.

How reproducible:

erm 100%

Steps to Reproduce:
1. run emacs
2. look at *Messages*
3. see that jka-comp got loaded..., or just read
/usr/share/emacs/site-lisp/default.el
  
Actual results:

auto-compression is turned on (and jka-comp is loaded) even if the user
customizes it off.

Expected results:

Not doing that, or at least removing the customization options so users won't
expect it to work.  Note that the customization code expects the default to be
off which it is in the unpatched emacs-21.x

Additional info:

One can work round it by simply doing something like:

; inhibit loading of default file which loads jka-comp
(set-variable 'inhibit-default-init t)

in the users' .emacs though then one needs to also do the mouse setup that
default.el does.  We could also just arrange to edit the default.el to remove
the added call.  Maybe it would be better to run it iff the customizaion is on.

 -- Jon
Comment 2 Radek Vokal 2010-04-13 10:56:13 EDT
This sounds like a very low impact bug. If you feel that the priority for this issue should be raised, please contact redhat.com/support.
Comment 3 Jonathan Peatfield 2010-04-13 11:12:52 EDT
Indeed is it is pretty low impact, and I didn't expect it to get fixed in a reasonable time - we can clearly fix it for our users.

My main purpose in reporting it was that anyone else suffering the problem (or as in our case having a couple of users who were confused by the behaviour) might stand a chance of finding a workround - even if they don't know much about emacs.

In general setting values which override user customizations is pretty bad-form and there would have been better ways to fix the problem that this hack was added to solve...

 -- Jon
Comment 4 Karel Klíč 2010-04-14 05:02:49 EDT
default.el is empty in recent Fedora releases and also in RHEL6

Note You need to log in before you can comment on or make changes to this bug.