Bug 31456 - XFree86 obsoletes XFree86-ISO8859-2 + XFConfig dead symlink
XFree86 obsoletes XFree86-ISO8859-2 + XFConfig dead symlink
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-11 14:27 EST by jens.koerber
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-17 19:05:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jens.koerber 2001-03-11 14:27:31 EST
... maybe include the remaining XFree86-ISO8859-2 fonts in
XFree86 (/usr/share/fonts/ISO8859-2/misc) and obsolete
the XFree86-ISO8859-2 package ...

I removed all the 3.3.x stuff from my system. The symlink

ln -snf ../../../../etc/X11/XF86Config
$RPM_BUILD_ROOT/usr/X11R6/lib/X11/XF86Config

is now dead ... I'm using

ln -snf ../../../../etc/X11/XF86Config-4
$RPM_BUILD_ROOT/usr/X11R6/lib/X11/XF86Config

(btw: thanks for the Xpilot optimizations ... together with the
ISDN-kernel changes in 2.2.19preX (unsupported ;-) this is the 
first ever playable version via ISDN ... :-)
Comment 1 jens.koerber 2001-03-11 14:48:05 EST
I rechecked the ISO8859-2 fonts and it looks like the stuff in
/usr/share/fonts/ISO8859-2/misc is already included in 
/usr/X11R6/lib/X11/fonts/misc  ...

So a  "Obsolete: XFree86-ISO8859-2" somewhere in XFree86.spec 
should be safe ..

Comment 2 Mike A. Harris 2001-03-17 19:05:25 EST
Putting an Obsoletes line anywhere would not work because the fonts
are split between three subpackages now.  Not sure how to handle this one..
Comment 3 Mike A. Harris 2001-06-01 02:06:15 EDT
The symlink isn't dead unless someone has deleted the file, or at
least it shouldn't be.  There is one included in the RPM.

The font thing is not easily resolveable IMHO without increasing complexity
significantly for no real major gain, and at the risk of hosing RHN.

Note You need to log in before you can comment on or make changes to this bug.