Bug 314591 - RHEL 4.7: SB700 contains two IDE channels
RHEL 4.7: SB700 contains two IDE channels
Status: CLOSED DUPLICATE of bug 335361
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
All Linux
high Severity medium
: ---
: ---
Assigned To: Bhavna Sarathy
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-01 15:26 EDT by Bhavna Sarathy
Modified: 2008-05-27 22:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 22:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bhavna Sarathy 2007-10-01 15:26:51 EDT
+++ This bug was initially created as a clone of Bug #314571 +++

Description of problem:
SB700 supports one physical IDE channel, but SB700 SATA controller
supports combined mode. When the SATA combined mode is enabled,
two SATA ports(port4 and port5) share one IDE channel from IDE
controller, and PATA will share the other IDE channel.

Our previous patch adding SB700 IDE device ID supported one
IDE channel. The attached patch supports two channels for the 
latest hardware.

The attached patch has been sent to the linux kernel IDE maintainer, 
and once accepted the upstream git link will be submitted to the BZ.
Comment 1 Bhavna Sarathy 2007-10-01 15:27:34 EDT
diff -ruN linux-2.6.23-rc5_orig/drivers/ide/pci/atiixp.c
linux-2.6.23-rc5/drivers/ide/pci/atiixp.c
--- linux-2.6.23-rc5_orig/drivers/ide/pci/atiixp.c	2007-09-01 14:08:24.000000000
+0800
+++ linux-2.6.23-rc5/drivers/ide/pci/atiixp.c	2007-09-28 00:35:55.000000000 +0800
@@ -325,7 +325,7 @@
 	{ PCI_VENDOR_ID_ATI, PCI_DEVICE_ID_ATI_IXP300_IDE, PCI_ANY_ID, PCI_ANY_ID, 0,
0, 0},
 	{ PCI_VENDOR_ID_ATI, PCI_DEVICE_ID_ATI_IXP400_IDE, PCI_ANY_ID, PCI_ANY_ID, 0,
0, 0},
 	{ PCI_VENDOR_ID_ATI, PCI_DEVICE_ID_ATI_IXP600_IDE, PCI_ANY_ID, PCI_ANY_ID, 0,
0, 1},
-	{ PCI_VENDOR_ID_ATI, PCI_DEVICE_ID_ATI_IXP700_IDE, PCI_ANY_ID, PCI_ANY_ID, 0,
0, 1},
+	{ PCI_VENDOR_ID_ATI, PCI_DEVICE_ID_ATI_IXP700_IDE, PCI_ANY_ID, PCI_ANY_ID, 0,
0, 0},
 	{ 0, },
 };
 MODULE_DEVICE_TABLE(pci, atiixp_pci_tbl);
Comment 2 Shane Huang 2008-05-27 22:27:28 EDT

*** This bug has been marked as a duplicate of 335361 ***

Note You need to log in before you can comment on or make changes to this bug.