This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 31462 - pdksh segfaults when using libtool with long command line
Summary: pdksh segfaults when using libtool with long command line
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pdksh (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-11 22:45 UTC by Arkadiusz Miskiewicz
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 19:20:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arkadiusz Miskiewicz 2001-03-11 22:45:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 i686; Nav)


Is segfaults (tries to free unallocated memory):
(gdb) bt
#0  0x0804a185 in ablockfree (bp=0x67206f6c, ap=0x807f188) at
alloc.c:471                           
#1  0x0804a04c in afree (ptr=0x812a6f8, ap=0x807f188) at
alloc.c:419                                
#2  0x080706d2 in setstr (vq=0x8124c28, s=0x8129398 "elector.lo
gnome-procbar.lo gnome-window.lo gnome-window-icon.lo gnometypes.lo 
gtkcauldron.lo gtk-clock.lo gtk-ted.lo gtkdial.lo gtkpixmapmenuitem.lo
-L/usr/lib -lesd -laudiofile+-lm -L/usr/lib -laudi"..., error_ok=1) at
var.c:372                                                
#3  0x08071316 in typeset (     var=0x8129388 "lib_search_path=elector.lo
gnome-procbar.lo gnome-window.lo gnome-window-icon.lo +gnometypes.lo
gtkcauldron.lo gtk-clock.lo gtk-ted.lo gtkdial.lo gtkpixmapmenuitem.lo
-L/usr/lib    +-lesd -laudiofile -lm -"..., set=0, clr=0, field=0,  base=0)
at
var.c:726                                                                            
#4  0x0805990d in comexec (t=0x80a52b0, tp=0x0, ap=0x80a51a8, flags=0) at
exec.c:575 
...                                                

Reproducible: Always
Steps to Reproduce:
Tested on libtool 1.3.5, pdksh 5.2.14:
1. cp /usr/bin/libtool ~/
2. vi ~/libtool and change s#!/bin/ksh
3. run libtool throught this (gdb) simple script (not directly):
mkdir -p /tmp/testXYZ && cd /tmp/testXYZ
~/libtool --mode=link gcc  -O2 -march=i686 -Wall -Wunused  -s -o
libgnomeui.la -rpath /usr/X11R6/lib -version-info 46:1:14 -rpath
/usr/X11R6/lib gnome-about.lo gnome-animator.lo gnome-app.lo
gnome-appbar.lo gnome-app-helper.lo gnome-app-util.lo gnome-calculator.lo
gnome-canvas.lo gnome-canvas-image.lo gnome-canvas-load.lo
gnome-canvas-line.lo gnome-canvas-rect-ellipse.lo gnome-canvas-polygon.lo
gnome-canvas-text.lo gnome-canvas-util.lo gnome-canvas-widget.lo
gnome-client.lo gnome-color-picker.lo gnome-dateedit.lo
gnome-dentry-edit.lo gnome-dialog.lo gnome-dialog-util.lo gnome-dns.lo
gnome-dock.lo gnome-dock-band.lo gnome-dock-item.lo gnome-dock-layout.lo
gnome-druid.lo gnome-druid-page.lo gnome-druid-page-start.lo
gnome-druid-page-standard.lo gnome-druid-page-finish.lo gnome-geometry.lo
gnome-guru.lo gnome-entry.lo gnome-file-entry.lo gnome-font-picker.lo
gnome-font-selector.lo gnome-href.lo gnome-ice.lo gnome-icon-list.lo
gnome-icon-item.lo gnome-icon-sel.lo gnome-icon-text.lo gnome-icon-entry.lo
gnome-init.lo gnome-less.lo gnome-mdi.lo gnome-mdi-child.lo
gnome-mdi-generic-child.lo gnome-mdi-session.lo gnome-messagebox.lo
gnome-number-entry.lo gnome-pixmap.lo gnome-pixmap-entry.lo
gnome-popup-menu.lo gnome-popup-help.lo gnome-preferences.lo
gnome-propertybox.lo gnome-properties.lo gnome-property-entries.lo
gnome-scores.lo gnome-spell.lo gnome-startup.lo gnome-stock.lo
gnome-winhints.lo gnome-paper-selector.lo gnome-procbar.lo gnome-window.lo
gnome-window-icon.lo gnometypes.logtkcauldron.lo gtk-clock.lo gtk-ted.lo
gtkdial.lo gtkpixmapmenuitem.lo -L/usr/lib -lesd -laudiofile -lm -L/usr/lib
-laudiofile -lm -ldb3 -L/usr/lib -lglib -ldl -L/usr/X11R6/lib -lgdk_imlib
-L/usr/X11R6/lib -L/usr/X11R6/lib -lgtk -lgdk -L/usr/lib -rdynamic
-lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -lSM -lICE -L/usr/X11R6/lib
-L/usr/X11R6/lib -lgtk -lgdk -L/usr/lib -rdynamic -lgmodule -lglib -ldl
-lXi -lXext -lX11 -lm -lz -lm 

Actual Results:  segfault 
Expected Results:  not segfault ;-)

Comment 1 Trond Eivind Glomsrxd 2001-03-12 15:34:48 UTC
Can you try getting the new kernel, pdksh and glibc from wolverine (or even
better: Rawhide) and try it again?

Also, how do you run that through gdb? I tried runninng the looong command line
in pdksh (after switching to ksh in ~/libtool), and couldn't reproduce your crash:

gcc: gtkdial.lo: No such file or directory
gcc: gtkpixmapmenuitem.lo: No such file or directory
$


Comment 2 Arkadiusz Miskiewicz 2001-03-12 19:20:16 UTC
Please ignore this bug report. I also have gcc 2.95.3-test4 (not from RH) and it
seems that it miscompiles pdksh. pdksh compiled using officiall compilator
from RH (I also tested this with gcc 20010305 snapshot) works fine.


Note You need to log in before you can comment on or make changes to this bug.