Bug 31477 - Installation of RH 7.1 Beta Wolverine onto an existing partition overwrites wrong partition
Installation of RH 7.1 Beta Wolverine onto an existing partition overwrites w...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-12 02:37 EST by Joachim Backes
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 15:46:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2001-03-12 02:37:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.18 i686)


I have 2 LINUX partitions on my SCSI disk: /dev/sda1 and /dev/sda3, where
/dev/sda3 is a direct copy of /dev/sda1. If I try an update installation of
my system residing on /dev/sda3 with RH 7.1 wolverine, then I'm asked after
the 'linear mode' question whether I want to write the boot record
on /dev/sda or /dev/sda1; I think, it would be a mistake to install the
boot record on /dev/sda1, it should be /dev/sda3.

Here, I stopped the installation.

In the fisher beta, I skipped the linear question and performed the
complete update, but, damned, then my primary RedHat on /dev/sda1 had been
overwritten !! And when I tried to boot from this /dev/sda1 partition,
after the kernel boot had been perfermed, and before starting the init
process, the boot crashed with the msg: 'kernel too old'.

Even if trying to reboot with my old boot diskette which normally enables
to boot from /dev/sda1, the booting crashed with the above msg. 

My mistake or RedHat's?

Regards

Joachim Backes <backes@rhrk.uni-kl.de>

Reproducible: Always
Steps to Reproduce:
1. see Description.
2.
3.
	

Actual Results:  see description

Expected Results:  see description

see description
Comment 1 Michael Fulbright 2001-03-12 11:16:09 EST
Your /etc/fstab file on the /dev/sda3 partition says that /dev/sda1 is the '/'
partition, doesn't it?
Comment 2 Joachim Backes 2001-03-13 01:01:22 EST
Oops, you're right. Indeed, I forgot to modify /etc/fstab. Additionally, I
forgot to madify /etc/lilo.conf too. That's my mistake. Please excuse for
troubles :)

Regards

Joachim Backes
Comment 3 Joachim Backes 2001-03-14 01:11:57 EST
Now, after a correct modification of /etc/fstab in /dev/sda3,
a tried again to make an update installation by the wolverine
RH Beta, with writing the boot loader into /dev/sda3 (not /dev/sda),
and writing a boot diskette.

After the finished installation, I tried to boot my system
now by using this new boot diskette, but after the kernel was
loaded, and before the init proc was started, the boot stopped
by a VFS panic message: could not use partition 08:03 for mounting.
MY impression is that on the boot diskette the scsi driver
aic7xxx.0 was missing (in the meanwhile, the diskette has been
overwritten so that I cannot report here contents).

Regards

Joachim Backes
Comment 4 Michael Fulbright 2001-03-14 15:31:36 EST
If you could possibly reproduce the issue it will help alot. I do not know of
any problems with aic systems booting from floppy.
Comment 5 Joachim Backes 2001-03-15 08:25:27 EST
Hi, I could reproduce the bug on an additional PC system! I suspect the
following:

My running kernel 2.2.18 has been bound together with aic7xxx, that means, the
disk dirver aic7xxx is not loaded as module in my normal system, therefore in
the copied system too which had been upgraded. But I suppose that the boot
diskette which was made by anaconda during the update was built with the very
modular 2.4.1 kernel residing on the RH 7.1 CD, which needs aic7xxx as lodable
module. But I suppose, this module is missing on the initrd on boot diskette.

The exact boot messages:

...
...
request-module [block-major-8]: Root fs not mounted
VFS: Cannot open root device "sda3" or 08:05
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:03

===================================

I tried to mount the boot diskette on another LINUX,
but is was not mountable:

mount /mnt/floppy
mount: /dev/fd0 already mounted or /mnt/floppy busy
root@sunny [root]: fsck /dev/fd0
Parallelizing fsck version 1.18 (11-Nov-1999)
e2fsck 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
fsck.ext2: Device or resource busy while trying to open /dev/fd0

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

Regards
Joachim Backes

--

Joachim Backes <backes@rhrk.uni-kl.de>       | Univ. of Kaiserslautern
Computer Center, Supercomputing Division     | Phone: +49-631-205-2438 
D-67653 Kaiserslautern, PO Box 3049, Germany | Fax:   +49-631-205-3056 
---------------------------------------------+------------------------
WWW: http://hlrwm.rhrk.uni-kl.de/home/staff/backes.html  

Comment 6 Joachim Backes 2001-03-15 08:27:49 EST
Please change
 
	VFS: Cannot open root device "sda3" or 08:05

into

	VFS: Cannot open root device "sda3" or 08:03

in my previous message (typing error).
Comment 7 Joachim Backes 2001-03-20 09:59:53 EST
Aditionally, an upgrade always is impossible (independent from an
additional partition) from RH 7.0 to WOLVERINE, if the SCSI disk driver
is not loaded as module.

Additionally, when making a boot diskette during the upgrade, and booting
after upgrading from this diskette, the loader stops with the message: Kernel
too old (see above too). This can be reproduced.
Comment 8 Michael Fulbright 2001-03-20 12:01:47 EST
Assigning to an engineer.
Comment 9 Brent Fox 2001-03-23 16:04:32 EST
Sounds like something could be wrong with your boot floppy if it can't be
mounted on a different machine.  The 'kernel too old' message is really weird
too.  I think that you may have mismatched boot disks or a bad floppy.
Comment 10 Joachim Backes 2001-03-25 23:54:27 EST
Again, the problem can be reproduced! The boot floppy was made by the RedHat
upgrade installer during upgrade (not by myself), exactly on the machine which
was booted afterwads. I tried it more than one time. 

How to reproduce:

1. Install pure RH 7.0
2. Make an own kernel (2.2.18 for example), where the SCSI driver is kernel
   inbound (no module)
3. Make an RH 7.1 upgrade with an boot floppy produced by the upgrade installer
4. Now test booting ;-)
4.
Comment 11 Brent Fox 2001-03-30 15:43:00 EST
The kernel on the installed system shouldn't have any effect on the installer,
since it has it's own kernel.  I don't understand steps 3 and 4 of your last
posting.  I'm not sure what "Make an RH 7.1 upgrade with an boot floppy produced
by the upgrade installer." means.
Comment 12 Joachim Backes 2001-04-03 07:54:25 EDT
Hi,

step 3 means: when upgrading from RH 7.0 to RH 7.1, then let the RH 7.1
              installer make a boot diskette (with th RH 7.1 kernel), when
              you are asked.

step 4 means: Now reboot your system with this boot diskette, if the update
	      is done.

Additionally: My remark to your remark

			"The kernel on the installed system shouldn't
			have any effect on the installer,
 			since it has it's own kernel."

               I think, this is an important point: exactly this is my
               problem. My opinion is -I repeat myself- that the RH 7.1
               installer forgets to install the correspondent scsi driver
	       module for my scsi interface card (adaptec 2940).

Regards

Joachim Backes

	
Comment 13 Brent Fox 2001-04-03 14:23:45 EDT
What happens if after upgrading if you boot the system without the bootdisk? 
I'm trying to see if we're making an incorrect boot disk or if the problem is
larger than that.
Comment 14 Joachim Backes 2001-04-04 00:46:50 EDT
AS I told you in a previous email, the system stops after kernel
loading, but before mounting the root fs with the following msg:

 ...
 ...
 request-module [block-major-8]: Root fs not mounted
 VFS: Cannot open root device "sda3" or 08:05
 Please append a correct "root=" boot option
 Kernel panic: VFS: Unable to mount root fs on 08:03
Comment 15 Brent Fox 2001-04-10 15:46:21 EDT
I think this is a dupe of 31477.  From what the folks in QA say, there were
problems with the aic7xxx, but the more recent kernels have fixed this.

Note You need to log in before you can comment on or make changes to this bug.