Bug 31489 - RFE: Use Mousewheel during installation
Summary: RFE: Use Mousewheel during installation
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-12 12:22 UTC by Patrick C. F. Ernzer
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 20:38:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick C. F. Ernzer 2001-03-12 12:22:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17-14 i686; en-US; 0.8)
Gecko/20010215


The installer does not use the scrollwheel. It wouyld be nice if it did
when the user selects a mousetype with scrollwheel.

Reproducible: Always
Steps to Reproduce:
1. boot into installer
2. select Microsoft intellimouse (IMPS/2)

	

Actual Results:  scrollwheel is ignored in installer

Expected Results:  scrollwheel should scroll if the focus is on a
scrollable window

Comment 1 Michael Fulbright 2001-03-12 16:11:16 UTC
Cannot detect presence of mouse wheel at this time.


Comment 2 Patrick C. F. Ernzer 2001-03-12 16:25:37 UTC
I was not expecting detection of a mouse wheel, I was expecting usage of the
mouse wheel when the selected mouse type is such that there is a wheel
(Intellimouse, Logitech MouseMan Wheel, ...)

Comment 3 Brent Fox 2001-04-11 20:37:58 UTC
If we can't detect it, we don't know that it's there.  If we don't know it's
there, we can't set it up when the installer first starts the X server.  Once
the X server is started, there is currently no way in X to load a new mouse
protocol without stopping and restarting the X server.  This is really an X
Windows problem.  If you start X Windows with a generic (non-wheel) mouse
specified in the configuration file, open a text editor and change the generic
mouse to something like Intellimouse, the change does not take effect until X is
restarted.

Comment 4 Ed McKenzie 2001-06-14 17:00:49 UTC
Does assuming the mouse has a wheel cause problems when it doesn't?  AFAIK the
wheel just acts like an extra set of buttons, which would just be ignored if no
such button events ever occur.

Comment 5 Brent Fox 2001-06-15 15:32:07 UTC
Yes, it can cause problems with X.  I don't really know why that happens, but I
have seen X crash when I selected the wrong mouse in the installer.  It seems to
have something to do with the hardware, though, because I can use the same mouse
on a different motherboard, and I don't have this problem.


Note You need to log in before you can comment on or make changes to this bug.