Bug 31524 - db2pdf backend (pdf) scrambles PDF file
Summary: db2pdf backend (pdf) scrambles PDF file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: docbook-utils   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-12 17:23 UTC by matti aarnio
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 18:10:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the 'pdf' backend fix (909 bytes, patch)
2001-03-12 17:23 UTC, matti aarnio
no flags Details | Diff

Description matti aarnio 2001-03-12 17:23:14 UTC
docbook-utils-0.6-11

Attached diff shows how I solved problems caused by  pdfjadetex output
being redirected to  INFILE.out  file - which for me resulted all of
that heading text to be prepended (in PDF form) to the generated PDF file.

Comment 1 matti aarnio 2001-03-12 17:24:00 UTC
Created attachment 12407 [details]
the 'pdf' backend fix

Comment 2 matti aarnio 2001-03-12 17:59:45 UTC
The   INFILE.out   is used by  (pdf)(jade)TeX  during the TOC construction,
and the way the original script is done, will result in chaos and mayhem...


Comment 3 Tim Waugh 2001-03-12 18:03:49 UTC
An alternative fix, then, would be to redirect to ${SGML_FILE_NAME}.tmp 
instead of .out.  Is that a better fix, do you think?


Comment 4 matti aarnio 2001-03-12 18:10:46 UTC
Yes, even though it feels somewhat like TeX might use that name too..


Comment 5 Tim Waugh 2001-03-12 18:47:33 UTC
I've used this .tmp fix in docbook-utils-0.6-12 in rawhide.  Thanks for the 
report.



Note You need to log in before you can comment on or make changes to this bug.