Bug 315271 - /etc/cron.daily/rpm is creating file with the wrong context.
Summary: /etc/cron.daily/rpm is creating file with the wrong context.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-10-02 11:58 UTC by Daniel Walsh
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 11:18:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Walsh 2007-10-02 11:58:35 UTC
Description of problem:

This script is creating rhe rpmpkgs file with the context root_t because it is
creating the file in / But it should be created as var_log_t.  The simplest way
to do this is to create the file in /var/log.

So first line should be

tmpfile=`/bin/mktemp /var/log/rpmpkgs.XXXXXXXXX` || exit 1

Otherwise lots of avc messages will be generated.

This needs to be fixed before Fedora 8 is released.

Comment 1 Panu Matilainen 2007-10-03 06:02:45 UTC
Fixed upstream, will be in 4.4.2.2 and F8

Comment 2 Panu Matilainen 2007-10-03 11:18:59 UTC
In rawhide now, but only available in builders ATM due to the F8-test3 freeze.


Note You need to log in before you can comment on or make changes to this bug.