Bug 31528 - If lilo fails, installer blindly continues
If lilo fails, installer blindly continues
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-12 12:57 EST by Warren Mansur
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 15:27:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Mansur 2001-03-12 12:57:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


The disk Redhat 7.0 was being installed on was given the 'hdb' label 
instead of 'hda'.  A CD-rom was also attached with the same cable which is 
why it was not chosen as the first disk.  At the end of the installation 
procedure, Redhat ran lilo and then rebooted.  The only problem was that 
lilo failed because it was being installed on the second disk.  Instead of 
Redhat noticing that lilo failed, and at least giving the user the option 
to edit lilo.conf, it  blindly rebooted.  Of course, upon rebooting, there 
was no boot loader installed, so Redhat did not boot.

It took me a long time to finally get hdb booted as root, edit lilo.conf, 
and then run lilo myself.  If I were given the option to edit lilo.conf 
just before Redhat rebooted, it would have saved hours of work.

Therefore, it is my opinion that if lilo fails, the Redhad installer 
should consider this a SERIOUS problem and not reboot.  In the best case, 
if the installer notices that lilo failed, it can give some sort of user 
friendly menu of possible problems it can try such as 1) installing on the 
second disk 2) installing past the 1024 cylinder boundary.  At the very 
least, the installer should allow the user to modify lilo.conf to get lilo 
working before rebooting.  If it blindly reboots the installer should know 
that Redhat will not boot and the user will be stuck.  There is no point 
to reboot if the boot loader is not installed.

Reproducible: Always
Steps to Reproduce:
1. Install Redhat on the second disk (hdb) OR install Redhat past the 1024 
cylinder boundary
2.
3.
	

Actual Results:  Upon reboot, Redhat Linux didn't start.

Expected Results:  Upon reboot, Redhat Linux should have started.
Comment 1 Michael Fulbright 2001-03-21 15:27:20 EST
We have added a screen when lilo fails, indicating the user should make a boot
floppy (the next screen in the installer) so they can get into the installed
system and fix the lilo.conf.

Note You need to log in before you can comment on or make changes to this bug.