This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 315471 - [RHEL 5.2]: Tick divider bugs on x86_64
[RHEL 5.2]: Tick divider bugs on x86_64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Chris Lalancette
Martin Jenner
: ZStream
Depends On: 305011
Blocks: 372911 420521 422431 422441
  Show dependency treegraph
 
Reported: 2007-10-02 11:05 EDT by Chris Lalancette
Modified: 2009-07-20 05:59 EDT (History)
12 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:56:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2007-10-02 11:05:49 EDT
+++ This bug was initially created as a clone of Bug #305011 +++

Description of problem:
On x86_64, the tick divider patch seems to have multiple bugs, which cause
problems on VMware ESX server.  In particular, because not all of the clocks are
being properly divided, it needs many more interrupts than a kernel re-compiled
to 100HZ would, and can cause time drift.  The problems identified so far are:

1)  It does not set the local APIC to the "divided" value; it leaves it at the
undivided value.
2)  It does not properly account for lost ticks when using PM-timer (it thinks
there are more lost ticks than there actually are).
3)  It does not properly account for lost ticks when using TSC.

A preliminary patch (based on input from VMware) is attached.

-- Additional comment from clalance@redhat.com on 2007-09-25 09:16 EST --
Created an attachment (id=205451)
Patch to fix some of the tick divider problems


-- Additional comment from marcobillpeter@redhat.com on 2007-09-28 13:15 EST --
requesting this for async errata after 5.1 GA release. The current broken 5.1
implementation will cause problems for fv and VMware clients.

requested for the first 5.1.z kernel errata

-- Additional comment from alan@redhat.com on 2007-10-02 08:37 EST --
Looks sane on a first glance
Comment 1 RHEL Product and Program Management 2007-10-18 17:36:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Don Zickus 2007-11-29 12:07:15 EST
in 2.6.18-58.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 5 Johnny Hughes 2008-01-03 07:13:57 EST
I would like to report that "divider=10 clocksource=pit" causes a hang on bootup.

This happens with the 2.6.18-53.1.4.el5 kernel and the latest one from the link
in #4 (kernel-2.6.18-62.el5).
Comment 7 Mike Gahagan 2008-05-02 16:21:12 EDT
confirmed fix is in the -92 kernel.
Comment 8 Akemi Yagi 2008-05-02 20:58:29 EDT
(In reply to comment #7)
> confirmed fix is in the -92 kernel.

I tried the -92 kernel from http://people.redhat.com/dzickus/el5.  However
addition of divider=10 AND clocksource=pit did cause a hang.  If I do not add
clocksource=pit, the system boots normally.  It looks like the issue still
exists in this test kernel.

Akemi
Comment 9 Chris Lalancette 2008-05-03 09:53:03 EDT
Right.  That bug is being tracked separately, here:

https://bugzilla.redhat.com/show_bug.cgi?id=427588

Chris Lalancette
Comment 11 errata-xmlrpc 2008-05-21 10:56:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.