Bug 31557 - Join processes allowing some sort of NULL?
Summary: Join processes allowing some sort of NULL?
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: Join_Process   
(Show other bugs)
Version: current
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Eddie Chen
QA Contact: Web Development
URL: http://www.redhat.com/apps/join
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-12 19:18 UTC by Martin C. Messer
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 19:14:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin C. Messer 2001-03-12 19:18:43 UTC
Customer with web_user.id of 563579 was created yesterday, 11-MAR-01, and
the Join app allowed what appears to be a single character wide space to be
entered as in the web_user_personal_info.last_name field. This breaks
things very badly, so the form validation should disallow any character
that is actually a just a space in any of the required fields (first name,
last name, address, city, state, zip, phone).

I update this web user's last name to be '.', and this allowed the Oracle
import processes to continue.

Comment 1 Martin C. Messer 2001-03-19 15:16:52 UTC
Another example:

web_user.id = 571196

In this case the web_user_personal_info.last_name appears to be a 6 character
wide null:

LENGTH(LAST_NAME)
-----------------
                6


Comment 2 Martin C. Messer 2001-03-19 15:39:40 UTC
New symptom: web_user_site_info.address1 is a 14 character wide null:

select length(ADDRESS1) from WEB_USER_SITE_INFO
where id = 1556680

LENGTH(ADDRESS1)
----------------
              14

Major problems here. Why would the Join process transform characters into nulls?

Comment 3 Martin C. Messer 2001-04-09 14:49:41 UTC
Another example of the problem:

web_user_site_info.id = 1603348
web_user.id = 595136

ADDRESS1 and CITY were both null. Already fixed these two since they were
holding up the mirror process.

Is this the Join process or the RHN reg client?

Comment 4 Martin C. Messer 2001-04-09 20:59:16 UTC
Two more examples from today:

WEB_USER_PERSONAL_INFO.ID = 595233

FIRST_NAMES and LAST_NAME are ' '

--

WEB_USER_SITE_INFO.ID 987736 and 987737 both have ' ' in ADDRESS1.



Comment 5 Jay Turner 2001-05-15 17:35:37 UTC
Are we any closer to knowing what is causing this?  Marty have you seen any more
examples of this happening on the site?

Comment 6 Eddie Chen 2001-05-22 18:19:44 UTC
I send an email to Adrian and Cristian regarding this problem back in March.

Subject: 
             Re: [Bug 31557] Changed - Join processes allowing some sort of
NULL?
       Date: 
             Mon, 19 Mar 2001 17:58:18 -0800
      From: 
             Eric Chen <echen@redhat.com>
         To: 
             "adrian@redhat.com" <adrian@redhat.com>, Cristian Gafton
<gafton@redhat.com>,
             "mmesser@redhat.com" <mmesser@redhat.com>
 References: 
             1




Adrian, 

I finally traced the problem  to rhn_register  and was able to create an 
account empty last name from my desktop,  can you take a look at this. 


Comment 7 Martin C. Messer 2001-05-22 19:14:17 UTC
Jay,

webdev isn't CC'ing to itself anymore. I just saw this.

I have no new reports of this.

Comment 8 Jay Turner 2001-09-17 20:06:53 UTC
Closing out this issue.


Note You need to log in before you can comment on or make changes to this bug.