Bug 31562 - installer fails doing an "upgrade" install from RC1 to RC2
Summary: installer fails doing an "upgrade" install from RC1 to RC2
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-12 20:10 UTC by Gregory Leblanc
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 21:49:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gregory Leblanc 2001-03-12 20:10:25 UTC
I received this message when doing an upgrade from RC1 to RC2.  I believe
this is after the packages installed, but I'm not 100% sure as I walked
away from the computer while the install ran.

Exception Occurred
<boilerplate>
Traceback(innermost last):
  File "/usr/bin/anaconda", line 507, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1216, in run
    rc = apply (step[1](). step[2])
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 643, in __call__
    in todo.doInstall ():
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1749, in
doinstall 
    (p, self.inft.messageWindow, pkgTimer))
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1748, in
instCallback
    fn = self.method.getFilename(h, pkgTime)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/image.py", line 87, in
getFilename
    isys.umount("/mnt/source")
  File
"/mnt/redhat/test/qa0302.0/i386/RedHat/instimage/usr/lib/anaconda/isys.py",
line 123, in umount
    rc = _isys.umount(what)
SystemError: (16, 'Device or resource busy')

Looking at this further, I suspect it was trying to eject the cdrom so that
it could use the second disk.

Comment 1 Jeremy Katz 2001-03-12 20:41:39 UTC
Were you using tty2 and poking around in a directory under /mnt/source?

Comment 2 Gregory Leblanc 2001-03-12 21:49:54 UTC
Hmm, yes, I was.  I needed a way to figure out what version of RH I was
installing, since the splash screen (lilo text, I guess) said 7.0.91, but I'd
labeled these CDs are RC2 (7.0.93).  Turns out the splash screen was wrong.  I
guess I should file that as another bug.


Note You need to log in before you can comment on or make changes to this bug.