Bug 31574 - Problem (system locks up) with PCMCIA on Toshiba Satellite 2180CDT
Problem (system locks up) with PCMCIA on Toshiba Satellite 2180CDT
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-12 17:25 EST by Inger Karin Haarbye
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 21:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2001-03-12 17:25:20 EST
On my Toshibas the PCMCIA-options in bios are:

Auto-Selected
CardBus/16-bit
PCIC Compatible

On Toshiba Sat. Pro 4280 PCMCIA works:

RedHat 7.0.9x:
PCIC in bios, PCIC=i82365 in /etc/sysconfig/pcmcia: 3c589_cs card works.
CARDBUS/16-bit or Autoselect in bios, PCIC=yenta_socket: 3c589_cs card and 
SMC Cardbus card (tulip) both works.

On Toshiba Sat. 2180:

With RedHat 7.0:
PCIC in bios, PCIC=i82365 in /etc/sysconfig/pcmcia: 3c589_cs card works.
Cardbus/16-bit or Autoselect in bios, PCIC=i82365 in /etc/sysconfig/pcmcia:
3c589_cs works. SMC Cardbus is recognized, and works if I upgrade 
Pcmcia-package.

With RedHat 7.0.9x:

PCIC in bios, PCIC=i82365 in /etc/sysconfig/pcmcia: Locks up on starting 
pcmcia!  Have to restart with button. Not always possible to recover the
file 
system.
Autoselect in bios, PCIC=i82365: Tells me to use pci=biosirq before it
locks 
up.... With pci=biosirq: locks up on starting pcmcia.

CardBus/16-bit in bios: No lockup this time, but i82365 is not loaded, and 
cards doesn't work. "no socket drivers loaded".

CardBus/16-bit in bios, /etc/sysconfig/pcmcia: PCIC=yenta_socket: Works
with 
SMC Cardbus card, locks up with 3c589_cs.

Autoselect in bios, PCIC=yenta_socket in /etc/sysconfig/pcmcia: Everything 
locks up when pcmcia is started.

Conclusion: 
PCMCIA works fine on my Toshiba Satellite pro 4280.

PCMCIA works fine with RedHat 7.0 on my Toshiba Satellite 2180.

With RedHat 7.0.9x PCMCIA Cardbus (SMC, tulip) works on Toshiba Sat. 2180 
with CardBus/16-bit in bios and PCIC=yenta_socket in /etc/sysconfig/pcmcia, 
but I can't get 3c589_cs to work on this laptop.
If I have PCIC-option in bios,  it will lock up on first boot after
install, 
even with no cards in the sockets!

I have now tried to compile new kernel (from 2.4.2-0.1.22 source) - and
install pcmcia-cs-3.1.25 from source. PCIC=i82365 in /etc/sysconfig/pcmcia.
Both cards works now.
Comment 1 Arjan van de Ven 2001-03-13 09:25:10 EST
Just to get it clear: 0.1.22 and later fix the problem for you?
Comment 2 Inger Karin Haarbye 2001-03-13 09:58:15 EST
No, not 0.1.19, not 0.1.22 - and not 0.1.25. I can't get the 3c589_cs card to
work at all with 7.0.9x, but if I compile kernel-2.4.2-0.1.22 from source -
without pcmcia-support, and compile pcmcia-cs-3.1.25 from source I can get it
work. It doesn't work at all with modules from 2.4.2 kernels from redhat.
Comment 3 Inger Karin Haarbye 2001-03-18 10:19:30 EST
The problem on this laptop is still the same with kernel-2.4.2-0.1.29 from
rawhide (on a qa0309 installation).
Comment 4 Dave Jones 2004-10-25 21:51:12 EDT
hopefully fixed in current releases, please reopen if reproducable with
Fedora/RHEL.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.