Bug 315991 - Unnecessary requires on Tomboy
Unnecessary requires on Tomboy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: conduit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 15:58 EDT by Brian Pepple
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.3.4-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 19:36:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Pepple 2007-10-02 15:58:57 EDT
Description of problem: conduit is pulling in Tomboy (and all the crap
associated with it) by default even though it's not a hard dependency.

Version-Release number of selected component (if applicable):
0.3.3-5

How reproducible: always

Steps to Reproduce:
1. yum install conduit
2. sit back and watch all the unnecessary mono packages be pulled in, even
though this is a python package.

Expected results: conduit install only the needed python packages.
Comment 1 Brian Pepple 2007-10-02 16:03:28 EDT
Also, I believe your Requires should be on dbus-python, not dbus.
Comment 2 Bernard Johnson 2007-10-02 17:35:31 EDT
When I first built the package, I thought that conduit would produce an error if
tomboy were not available to sync to.  I later found out that it will detect the
presence of tomboy at runtime, I just haven't had a chance to update the spec
file since then.

I'll check into the dbus-python issue as well.  Thanks.
Comment 3 Brian Pepple 2007-10-02 17:50:43 EDT
Yeah, this should be pretty easy to fix.  If you don't have time, I can.
Comment 4 Bernard Johnson 2007-10-30 22:42:34 EDT
(In reply to comment #1)
> Also, I believe your Requires should be on dbus-python, not dbus.

It seems a little more complicated than that.  dbus-python is required, but
dbus-python does not require dbus (go figure).  So both dbus and dbus-python are
required.
Comment 5 Fedora Update System 2007-11-06 11:09:26 EST
conduit-0.3.4-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update conduit'
Comment 6 Fedora Update System 2007-11-09 18:41:58 EST
conduit-0.3.4-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update conduit'
Comment 7 Fedora Update System 2007-11-15 19:36:09 EST
conduit-0.3.4-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2007-11-15 19:41:42 EST
conduit-0.3.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.