Bug 3160 - Cannot specify hexadecimal internal IPX network number
Cannot specify hexadecimal internal IPX network number
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-30 16:50 EDT by Adam Thompson
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-15 15:56:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Thompson 1999-05-30 16:50:04 EDT
Linuxconf (linuxconf-1.14r4-4) does not allow the letters
"A" through "F" in the "Internet Network Number(opt)" field
of the IPX configuration dialog.

IPX network numbers are expressed in hexadecimal, and the
IPX utilities treat the number entered as a hexadecimal
number.  Many sites (including mine) require that internal
network numbers adhere to a specific standard that often
includes (as in my case) A through F.

I would assume that the other "network number" fields in
this dialog have the same behaviour, but those are less
critical because they can be autoprobed.  The internal net#
cannot be autoprobed, by definition.

The workaround is to directly edit
/etc/sysconfig/network-scripts/ifcfg-eth0 afterwards and
reboot (or at least start/stop IPX - it's usually easier to
reboot).
Comment 1 Michael K. Johnson 1999-07-29 18:01:59 EDT
Added Jacques to the CC line so that he can investigate this bug.
Comment 2 jack 1999-11-30 12:10:59 EST
This was fixed after 1.14r4. Can't remember exactly when. Tested on 1.16r10.
Comment 3 Michael K. Johnson 1999-12-02 11:55:59 EST
So this may be fixed in the linuxconf-1.16r1.3-1 errata release that we
did for 6.0, may not exist in linuxconf-1.16r3.2-2 released in 6.1, and
will certainly not exist in linuxconf-1.16r10-1 or later which we will,
after some testing, release as an errata update to 6.1.

------- Email Received From  "Adam N. Thompson" <athompso@pangea.ca> 12/03/99 02:03 -------
Comment 4 Dale Lovelace 1999-12-03 13:42:59 EST
This is indeed fixed in 1.16r10
Comment 5 Michael K. Johnson 1999-12-15 15:56:59 EST
1.16r10-2 released

Note You need to log in before you can comment on or make changes to this bug.