Bug 316191 - curl-config doesn't advertise support of SSL and HTTPS when built against nss
curl-config doesn't advertise support of SSL and HTTPS when built against nss
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: curl (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: EasyFix, Patch, Regression
Depends On:
Blocks: 316971
  Show dependency treegraph
 
Reported: 2007-10-02 17:06 EDT by Lubomir Kundrak
Modified: 2013-07-02 19:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 09:33:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to make curl-config not forget about NSS for SSL support (1.15 KB, patch)
2007-10-02 17:11 EDT, Lubomir Kundrak
no flags Details | Diff

  None (edit)
Description Lubomir Kundrak 2007-10-02 17:06:06 EDT
Description of problem:

curl-config --features output doesn't include SSL and curl-config --protocols
output doesn't include HTTPS since curl wasn't built with OpenSSL.

Version-Release number of selected component (if applicable):

curl-7.16.4-7.fc8

Steps to Reproduce:
1. curl-config --protocols |grep HTTPS
2. curl-config --features |grep SSL
  
Actual results:

Expected results:

HTTPS
SSL
:)
Comment 1 Lubomir Kundrak 2007-10-02 17:11:33 EDT
Created attachment 214001 [details]
Patch to make curl-config not forget about NSS for SSL support
Comment 2 Jindrich Novy 2007-11-08 09:33:22 EST
Applied, thanks.

Note You need to log in before you can comment on or make changes to this bug.