Bug 316491 - "Error attaching device data" in RHEL5 with ACPI
"Error attaching device data" in RHEL5 with ACPI
Status: CLOSED DUPLICATE of bug 459670
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
athlon Linux
low Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 02:35 EDT by enrico
Modified: 2008-08-22 15:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-22 15:01:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (20.65 KB, text/plain)
2007-10-03 02:35 EDT, enrico
no flags Details

  None (edit)
Description enrico 2007-10-03 02:35:13 EDT
Description of problem:
I got a message from dmesg in my system, it shows 8 "error attaching device 
data" after booting to RHEL5 64bit.My configuration is 2 AMD Barcelona 2347. It 
also happended with AMD ref.F CPU, but only 4 lines "error attaching device 
data" displayed on th screen. It's dependent on numbers of total cpu cores.

Below is the dmesg, 

checking if image is initramfs... it is
Grant table initialized
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: Using configuration type 1
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
Error attaching device data
Error attaching device data
Error attaching device data
Error attaching device data
Error attaching device data
Error attaching device data
Error attaching device data
Error attaching device data
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
Boot video device is 0000:01:05.0
PCI: Transparent bridge - 0000:00:06.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.BR10._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.BR12._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.BR12.BR1E._PRT]


I do some tests and found if the proccessor use alias in the \_PR like below, 
this message will appear. 

Scope(\_PR) {

	Processor( P001, 1, 0x2010, 6){}
	Processor( P002, 2, 0x0, 0){}
	Processor( P003, 3, 0x0, 0){}
	Processor( P004, 4, 0x0, 0){}
	Processor( P005, 5, 0x0, 0){}
	Processor( P006, 6, 0x0, 0){}
	Processor( P007, 7, 0x0, 0){}
	Processor( P008, 8, 0x0, 0){}

	Alias(P001,CPU1)
	Alias(P002,CPU2)
	Alias(P003,CPU3)
	Alias(P004,CPU4)
	Alias(P005,CPU5)
	Alias(P006,CPU6)
	Alias(P007,CPU7)
	Alias(P008,CPU8)
} // end Processor scope

If I do not use alias like below, this message will disappear. 

Scope(\_PR) {

	Processor( CPU1, 1, 0x2010, 6){}
	Processor( CPU2, 2, 0x0, 0){}
	Processor( CPU3, 3, 0x0, 0){}
	Processor( CPU4, 4, 0x0, 0){}
	Processor( CPU5, 5, 0x0, 0){}
	Processor( CPU6, 6, 0x0, 0){}
	Processor( CPU7, 7, 0x0, 0){}
	Processor( CPU8, 8, 0x0, 0){}
} // end Processor scope

I believe the alias is the standard usage in ACPI Spec, is it linux kernel bug 
or ??

Do anyone have idea?
Comment 1 enrico 2007-10-03 02:35:13 EDT
Created attachment 214371 [details]
dmesg
Comment 2 Linda Wang 2008-08-22 15:01:14 EDT

*** This bug has been marked as a duplicate of bug 459670 ***

Note You need to log in before you can comment on or make changes to this bug.