Bug 316501 - file hugging cpu
file hugging cpu
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 03:41 EDT by Hubert Lin
Modified: 2008-02-03 05:32 EST (History)
0 users

See Also:
Fixed In Version: 4.21-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-02 03:59:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the file that fails the *file* util (880.41 KB, application/x-executable)
2007-10-03 03:41 EDT, Hubert Lin
no flags Details

  None (edit)
Description Hubert Lin 2007-10-03 03:41:58 EDT
Description of problem:

While testing the file type with the file attached, the process hugs the cpu and
never returned.

Version-Release number of selected component (if applicable):
file-4.21-1.fc6

How reproducible:
Always.

Steps to Reproduce:
1. file e5f5fdb10c8bb35d3219a87516147e15.exe
  
Actual results:
The process never exits, which CPU hugging.

Expected results:
Shows file type info.

Additional info:
The file size attached is less than 1 MB, and is infected by
Trojan.Downloader.Small-1444 (scanned by ClamAV).
Comment 1 Hubert Lin 2007-10-03 03:41:59 EDT
Created attachment 214381 [details]
the file that fails the *file* util
Comment 2 Tomas Smetana 2007-12-11 03:10:55 EST
Reproduced.  I'll take a look at it.  Thanks for reporting.
Comment 3 Tomas Smetana 2007-12-11 03:11:48 EST
And changed version to rawhide, so the bug doesn't get closed automatically.
Comment 4 Tomas Smetana 2008-01-16 07:36:44 EST
The process exits -- it's only extremely slow:
e5f5fdb10c8bb35d3219a87516147e15.exe: PE32 executable for MS Windows (GUI) Intel
80386 32-bit

The problem is in the regexec function provided by glibc.  Unfortunately I can't
reproduce the problem anywhere else but in the file binary.  I've tried to take
the exect regular expression that seems to cause the problem but no luck.  If I
reproduce it I may file a bug on glibc.  If not, I'll try to rewrite the regular
expression to it's equivalent and see whether that helps.
Comment 5 Tomas Smetana 2008-01-29 03:46:06 EST
Fixed in 4.23-1.fc9.  Will push also update for F-8.
Comment 6 Fedora Update System 2008-01-29 04:15:39 EST
file-4.21-5.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-02-02 03:59:44 EST
file-4.21-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Hubert Lin 2008-02-03 05:32:29 EST
Just verified it's fixed in file-4.21-5.fc8.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.