Bug 316601 - [hts-5.1.1][x86_64][network][RHEL5.1] - Network Testing Fails randomly
[hts-5.1.1][x86_64][network][RHEL5.1] - Network Testing Fails randomly
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 06:18 EDT by Satyabrata Maitra
Modified: 2008-07-16 17:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 10:35:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network-files for latest run which FAIL, with tree 20070927.0 (370.00 KB, application/x-tar)
2007-10-03 06:18 EDT, Satyabrata Maitra
no flags Details
network-files for prior run which PASS, with tree 20070927.nightly (370.00 KB, application/x-tar)
2007-10-03 06:20 EDT, Satyabrata Maitra
no flags Details
RHEL5.1 - results.xml where it FAILS showing, with 20070927.0 tree in latest rest (786.39 KB, text/xml)
2007-10-08 02:44 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2007-10-03 06:18:13 EDT
Description of problem:
When testing for network on RHEL5.1-Server with x86_64 arch for hts-5.1.1,
sometimes its FAILs, and sometimes It PASS. Both the .tar file along with all
log file and .rpm file and sysreports are attached with this bug.

Version-Release number of selected component (if applicable):
hts-5.1.1
tree followed - 20070927.0

How reproducible:
randomly

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Its randomly FAILS

Expected results:
It should be PASS each time

Additional info:
Comment 1 Satyabrata Maitra 2007-10-03 06:18:13 EDT
Created attachment 214451 [details]
network-files for latest run which FAIL, with tree 20070927.0
Comment 2 Satyabrata Maitra 2007-10-03 06:20:02 EDT
Created attachment 214461 [details]
network-files for prior run which PASS, with tree 20070927.nightly
Comment 3 Greg Nichols 2007-10-03 10:37:58 EDT
Both attachments indicate the network test passed.  Could you attach
/var/log/results.xml for the failing case?

Thanks!
Comment 4 Satyabrata Maitra 2007-10-08 02:44:00 EDT
Created attachment 219051 [details]
RHEL5.1 - results.xml where it FAILS showing, with 20070927.0 tree in latest rest
Comment 5 Satyabrata Maitra 2007-10-08 02:55:56 EDT
Actully if both the tests are PASS showing as you said, so, I think the hardware
catelog result is not showing perfectly. Because, The PASS or FAIL status, I
collected from after creating the certification for both the latest and prior
.rpm file. 
Anyway, the results.xml file for the FAILING Test is attached now, pls suggest.
And surprisingly the test, where it was PASS, there the /var/hts/results.xml
file is showing empty, no content showing within that file. :(. really do not
know the reason. Anyway..
Latest certification number with 20070927.0 tree is - 265328
Prior certification number with 20070927.nightly tree is - 265324
Please see and suggest if there is any confilct with the actual result and the
result status showing in hwcert.
Comment 6 Greg Nichols 2007-10-08 09:49:35 EDT
Here's the log from the failed network test:

Running ./network.py:
using test server 10.12.4.144
Interface eth1 is down
Bringing up interface eth1
ifup eth1 returned 0
Error: could not restart interface eth1
Error: could not bounce interface eth1
...finished running ./network.py, exit code=1

So, the test could not bring up the interface eth1.   I suspect eth1 was not
connected to a network.  Can you verify that it was>

Thanks!
Comment 7 Satyabrata Maitra 2007-10-09 02:45:37 EDT
Hi Greg
Is it necessary that eth1 must be connected to a network for all the systems or
it must be there in the system active all the time? If not, so, eth1 should FAIL
always in such cases. right? In such cases, what to do? Even if eth1 Fails, if
eth0 is PASS, should I treat the Network test as PASS? Please inform. Anyway, I
will check it once more retesting it and get back to you with result. :)
Comment 8 Satyabrata Maitra 2007-10-16 07:15:54 EDT
Greg
As I tested it with hts5.1-4 once again, at the time of testing its showing in
terminal, that eth1 or eth2 or eth3 (which ever appears in test plan) is FAILED,
and suggesting me to check the cable. That means, the cable surely not connected
even if the ethernet cards are attached with that system. As I did it on
reserved system, not possible for me to check it by person. But seems that, each
of these case, the cable not connected. Am i right? Please inform.
Comment 9 Greg Nichols 2007-12-03 10:35:03 EST
Yes, if one of the interfaces was not connected, HTS will fail the network test
for that interface, and the hardware catalog will mark the network test as a
failure.

Closing this as not a bug.

Note You need to log in before you can comment on or make changes to this bug.