Bug 316621 - snmpd segfaults
snmpd segfaults
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 06:27 EDT by Thomas Antony
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 5.4-15.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 17:29:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from 'snmpd -f -Lo -DALL' (66.97 KB, application/octet-stream)
2007-10-06 07:15 EDT, Thomas Antony
no flags Details

  None (edit)
Description Thomas Antony 2007-10-03 06:27:49 EDT
Description of problem:
snmpd segfaults immediately after starting

[thomas@srv1 ]$ sudo gdb snmpd
GNU gdb Red Hat Linux (6.6-15.fc7rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
Using host libthread_db library "/lib64/libthread_db.so.1".
(gdb) r -a -f
Starting program: /usr/sbin/snmpd -a -f
[Thread debugging using libthread_db enabled]
[New Thread 46912544335328 (LWP 28328)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912544335328 (LWP 28328)]
0x00002aaaad1aac20 in strcpy () from /lib64/libc.so.6
Comment 1 Thomas Antony 2007-10-03 09:46:22 EDT
This is logged to /var/log/messages

snmpd[4132]: segfault at 0000000000000001 rip 00002aaaad1aac20 rsp
00007fff63bf37d8 error 4
Comment 2 Jan Safranek 2007-10-05 06:42:06 EDT
net-snmp-5.4-14.fc7 is working for me. Please specify more precisely your
configuration, including:
- architecture
- kernel version
- net-snmp version
- content of /etc/snmp/
- eventually whole coredump

It's hard to guess what's wrong without this information. You can also run
'snmpd -f -Lo -DALL' and attach the output (beware, it can be long). 

Thanks in advance
Comment 3 Thomas Antony 2007-10-06 07:15:47 EDT
Created attachment 218361 [details]
output from 'snmpd -f -Lo -DALL'
Comment 4 Thomas Antony 2007-10-06 07:20:20 EDT
I'm running F7 x86_64 with kernel-xen-2.6.20-2936.fc7 and net-snmp-5.4-14.fc7

[root@srv1 ~]# ls -l /etc/snmp/
total 24
-rw-rw-r-- 1 root root   700 2007-10-06 13:05 snmpd.conf
-rw-r--r-- 1 root root 18628 2007-07-31 22:46 snmpd.conf.original


[root@srv1 ~]# cat /etc/snmp/snmpd.conf
###########################################################################
#
# snmpd.conf
#
#   - created by the snmpconf configuration program
#


###########################################################################
# SECTION: Access Control Setup
#
#   This section defines who is allowed to talk to your running
#   snmp agent.

# rocommunity: a SNMPv1/SNMPv2c read-only access community name
#   arguments:  community [default|hostname|network/bits] [oid]

rocommunity  public localhost
rocommunity  public 192.168.88.10
rocommunity  public 127.0.0.1
rocommunity  public srv1

# Allow Systems Management Data Engine SNMP to connect to snmpd using SMUX
smuxpeer .1.3.6.1.4.1.674.10892.1
Comment 5 Thomas Antony 2007-10-06 07:27:12 EDT
When i comment out smuxpeer, snmpd is starting and working.
I'm running F7 on a Dell PE2950.
Comment 6 Jan Safranek 2007-10-08 03:56:07 EDT
thanks, that's I need to know. As you indicated, the problem is in the
'smuxpeer' in the snmpd.conf. You must specify a password:

smuxpeer .1.3.6.1.4.1.674.10892.1 my_password

I'll try to fix it to display some meaningful message instead of segfault...
Comment 7 Jan Safranek 2007-10-08 05:53:16 EDT
I backported fix from net-snmp-5.4.1 to Fedora7, update will be available in
testing repository soon.
Comment 8 Fedora Update System 2007-10-08 11:03:14 EDT
net-snmp-5.4-15.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update net-snmp'
Comment 9 Thomas Antony 2007-10-10 08:06:56 EDT
I tested those rpm's and now smuxpeer accepts no passwords and doesn't segfault.
Works for me!
Comment 10 Fedora Update System 2007-10-15 17:29:29 EDT
net-snmp-5.4-15.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.