Bug 316931 - v4l2src plugin regression with uvcvideo: uses read() rather than mmap()
v4l2src plugin regression with uvcvideo: uses read() rather than mmap()
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 10:43 EDT by Michel Alexandre Salim
Modified: 2008-01-16 11:28 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.10.6-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 11:28:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix V4L2 buffer issue (552 bytes, patch)
2007-12-08 15:31 EST, Ignacio Vazquez-Abrams
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 467214 None None None Never
GNOME Desktop 477456 None None None Never

  None (edit)
Description Michel Alexandre Salim 2007-10-03 10:43:44 EDT
Description of problem:
The v4l2 plugin in 0.10.6 uses read() exclusively; right now the linux-uvc
project only supports mmap() as it performs better.

Version-Release number of selected component (if applicable):
gstreamer-plugins-good-0.10.6-5.fc8

How reproducible:
Always

Steps to Reproduce:
1. Install linux-uvc and plug in a UVC webcam (Logitech, Thinkpad)
2. gstreamer-properties, set device to v4l2, test

Actual results:
Failure -- could not get buffers from /dev/video0

Expected results:
Should work (Ekiga works)


Additional info:
Fixed in CVS -- could the patch be applied?
Comment 1 Michel Alexandre Salim 2007-11-11 19:24:52 EST
Still a problem with the latest version of linux-uvc -- ping?
Comment 2 Ignacio Vazquez-Abrams 2007-12-08 14:18:01 EST
Looks like a single change will fix this, although __tim in #gstreamer says that
it should be set to GST_V4L2_MIN_BUFFERS instead of 2.

http://webcvs.freedesktop.org/gstreamer/gst-plugins-good/sys/v4l2/gstv4l2src.c?r1=1.83&r2=1.84
Comment 3 Ignacio Vazquez-Abrams 2007-12-08 15:31:30 EST
Created attachment 282101 [details]
Patch to fix V4L2 buffer issue

The attached patch fixes the issue for F8/x86_64.
Comment 4 Thomas J. Baker 2007-12-11 13:36:11 EST
The include patch works for me and makes the webcam on my M1210 work with cheese...
Comment 5 Chuck Ebbert 2008-01-11 17:48:39 EST
Where are you getting linux-uvc from?
Comment 6 Michel Alexandre Salim 2008-01-11 18:12:57 EST
Compiled from SVN sources. I have a package for it, but it depends on DKMS, and
I'm not sure Fedora currently accepts DKMS-packaged kernel modules.
Comment 7 Fedora Update System 2008-01-15 18:10:26 EST
gstreamer-plugins-good-0.10.6-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.