Bug 31698 - netscape crashes on startup
netscape crashes on startup
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-13 12:17 EST by Need Real Name
Modified: 2014-03-16 22:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 11:43:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-13 12:17:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-0.1.9 i686; en-US; 0.7)
Gecko/20010203


After using it successfully for about a week, Netscape now crashes on startup:

$ netscape-communicator
Bus error (core dumped)

It produces the following stack trace:


#0  0x40237fb1 in __kill () from /lib/libc.so.6
(gdb) where
#0  0x40237fb1 in __kill () from /lib/libc.so.6
#1  0x08940170 in PR_ClearPendingException () at eval.c:41
#2  <signal handler called>
#3  0x0828118a in __strdup () at strdup.c:41
#4  0x08834785 in SECMOD_InitDB () at eval.c:41
#5  0x08839cac in SECMOD_init () at eval.c:41
#6  0x087eb0ef in SECNAV_Init () at eval.c:41
#7  0x082bf853 in main () at eval.c:41
#8  0x40227091 in __libc_start_main (main=0x82be7a4 <main>, argc=3,
    ubp_av=0xbffff85c, init=0x827f548 <_init>, fini=0x894914c <_fini>,
    rtld_fini=0x4000e374 <_dl_fini>, stack_end=0xbffff854)
    at ../sysdeps/generic/libc-start.c:129

The problem is consistent: even removing ~/.netscape doesn't resolve the
problem.

This is with netscape-communicator 4.76-10.


Reproducible: Always
Steps to Reproduce:
1.start netscape-communicator
Comment 1 Bill Nottingham 2001-03-13 12:22:40 EST
Does it persist if you run 'LANG=C netscape'?
Comment 2 Need Real Name 2001-03-13 13:20:38 EST
Yes: the problem is exactly the same, as is the stack trace.
Comment 3 Gissehel, Arthibus 2001-04-25 01:50:05 EDT
I've the same probleme:
version 4.76 and 4.77 of netscape ALWAYS crash, either on RH L 7.0 or RH L 7.1
version 4.75 nevers crash (RH 7.0 or RH 7.1).

the 4.75 package from RH 7.0 works perfectly on RH 7.1

I've got a "Cyrix P200+", may be there's a probleme with that. I saw some
applications that can't work on Cyrix generating a "Bus Error".

(Netscape is the only application where I have a bus error, so that's probably
not a hardware faillure...)

Comment 4 stano 2001-07-13 15:06:10 EDT
One more datapoint: Netscape crashed on startup for me, then I removed .netscape
and it crashes one step later - goto groups.google.com, "innxmit RedHat",
<enter>, bang... RH 7.1, netscape 4.76, didn't try 4.77 yet.

In my case LANG=C _does_ help (I use LANG=sk_SK normally, without any other
locale variables set).
Comment 5 Need Real Name 2001-08-07 11:43:47 EDT
I've got the problem too, and can demonstrate it.  If someone from Red Hat 
will contact me, I can offer an account where you can connect with VNC and 
see the problem for yourself.

Also I have an earlier version of my root filesystem that I can boot up and 
the problem does NOT occur.  The difference is mostly that the failing 
system has seen some more configuration work, and is running Apache, 
Courier IMAP and Postfix.  Both are using the same kernel and glibc, and
environment setups seem to be the same.

More specifically, the problem I see is:

$ netscape
netscape-communicator: locale `en_US' not supported by Xlib; tryping `C'.
netscape-communicator: locale `C' not supported either.
        Perhaps the $XNLSPATH environment variable is not set correctly?
Bus error (core dumped)
$

Of course "LANG=C" does not help.

-- Rod
   rod@sunsetsystems.com
Comment 6 Bill Nottingham 2002-01-23 22:38:32 EST
Unfortunately, crashes like this indicate problems in the core netscape code,
which we really can't fix, as we don't have access to it. Reporting it to
netscape may be more fruitful. 

We can't reproduce these crashes here in our testing.

Note You need to log in before you can comment on or make changes to this bug.