Bug 3170 - Enlightenment hangs if xtrs is run
Enlightenment hangs if xtrs is run
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 1999-05-30 20:33 EDT by Tim Mann
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-08-31 20:31:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Mann 1999-05-30 20:33:43 EDT
Running the TRS-80 emulator "xtrs" under Enlightenment
causes the window manager to hang.  The mouse still moves
and mouse cursors change, but text cannot be typed into any
window, windows can't be raised or lowered, no menus come
up, if the Gnome panel is on autohide, it can't be pulled
up, etc.  Basically, nothing works.  This happens before
xtrs displays a window.

I can recover by using Ctrl+Alt+F2 to log in again, killing
xtrs, killing Enlightenment (this is necessary), and
starting a new copy of Enlightenment.  It remanages all the
windows and things are OK again.

xtrs runs fine under GNOME + WindowMaker, by the way.

xtrs's X code was originally written a long time ago, and
uses Xlib directly.  It doesn't use any toolkit, not even
Xt.  However, it hasn't killed any other window managers
I've tried it with (and no other xtrs users have reported
problems to me).

You can get a copy of xtrs to try from my TRS-80 page,
I realize that getting xtrs running to reproduce the bug may
be a bit of a pain, so if you have things I could try here
to gather more information, just email me and I'll be glad
to give it a shot.

Comment 1 Cristian Gafton 1999-07-29 03:21:59 EDT
assigned to msf
Comment 2 Elliot Lee 1999-08-03 15:29:59 EDT
Behaviour confirmed.
Comment 3 Elliot Lee 1999-08-31 20:31:59 EDT
I've put a patch into the E package to fix this. (0.15.5-41)

Note You need to log in before you can comment on or make changes to this bug.