Bug 31717 - Boot partition in kickstart is not allocated < 1024 if on RAID
Summary: Boot partition in kickstart is not allocated < 1024 if on RAID
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-13 21:45 UTC by Jos Vos
Modified: 2007-03-27 03:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-10 21:43:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.cfg file that causes the "Disk Setup" screen to appear (3.03 KB, text/plain)
2001-03-14 21:17 UTC, Jos Vos
no flags Details

Description Jos Vos 2001-03-13 21:45:44 UTC
It (still...) seems to be impossible to auto-install a RAID1 system.

Scenario 1:
I include "part raid.xx --size yy --ondisk sda/b" and then "raid /zz
--level1 --device mdX raid.xx raid.yy".  Then everything works, *except*
that /boot, being the smallest partition, appears at the end of the disks
(sda9/sdb9 as md0 in my case) and lilo won't work because of the too large
cylinder numbers.

Scenario 2:
Trying to "help" a bit with specifying "--asprimary" for the "part"
statements that later becomes the /boot volume.  Now it doesn't work at
all: on VC3 these messages appear:

Failed to allocate 'raid.01': Allocation succeeded
Failed to allocate 'raid.02': Allocation succeeded

and Anaconda gives me the "Disk Setup" main window to do it myself :-(.

Comment 1 Michael Fulbright 2001-03-14 16:16:00 UTC
Looking into a related issue at the moment, will see if same case.

Comment 2 Michael Fulbright 2001-03-14 20:18:11 UTC
Please attach your ks.cfg as an attachment please.

Comment 3 Glen Foster 2001-03-14 20:49:19 UTC
This defect considered MUST-FIX (Show-stopper) for Florence Gold

Comment 4 Jos Vos 2001-03-14 21:17:54 UTC
Created attachment 12666 [details]
ks.cfg file that causes the "Disk Setup" screen to appear

Comment 5 Jos Vos 2001-03-14 21:19:30 UTC
Additional note:
Leaving out the --asprimary flags in the previously attached ks.cfg file causes
the system to install, but putting /boot at an unreachable place (at the end of
the disks...).

Comment 6 Michael Fulbright 2001-03-16 01:08:58 UTC
Fixed.

Still leaves problem that if the boot partition is on RAID, it is not marked to
be put < 1024 cylinders. This code is in the GUI disk druid, but not the python
code for kickstart. Deferring for now because of lateness in cycle, and there is
a workaround.

Comment 7 Jos Vos 2001-03-16 09:19:38 UTC
Does this mean --asprimary (and --onprimary 1 as well?) now works?

Comment 8 Jeremy Katz 2001-09-10 21:43:04 UTC
This should be fixed in Enigma


Note You need to log in before you can comment on or make changes to this bug.