Bug 317211 - python-html2text consists of /html2text.py
python-html2text consists of /html2text.py
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-html2text (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 15:18 EDT by Doncho N. Gunchev
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 01:01:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2007-10-03 15:18:19 EDT
Description of problem:
python-html2text consists of /html2text.py

Version-Release number of selected component (if applicable):
python-html2text-2.26-2.1

How reproducible:
always

Steps to Reproduce:
1. yum install python-html2text
2. rpm -ql python-html2text

Actual results:
/html2text.py

Expected results:
3 files - .py .pyc .pyo and LICENSE maybe, in the proper directory

Additional info:
python-html2text-2.26-2.fc7.noarch.rpm looks fine (3 files).
There also is http://www.aaronsw.com/2002/html2text/html2text-2.28.py 
available.

Looking at the .spec files from koji they don't differ much, koji build 
problem I guess - license, release (lost %{?dist} and changelog.
Comment 1 Patrice Dumas 2007-10-03 18:07:43 EDT
Looks like a packaging bug to me: a missing
BuildRequires: python
that leads to %{python_sitelib} being empty.


Comment 2 Thorsten Leemhuis 2007-10-04 01:01:59 EDT
thx for reporting, should be fixed in python-html2text-2_26-3_1
Comment 3 Doncho N. Gunchev 2007-10-04 08:06:13 EDT
OT: What about also updating to 2.28 - the diff from 2.26 is 3-4 lines and is 
a bugfix?

Note You need to log in before you can comment on or make changes to this bug.