Bug 31789 - error in rc.sysinit
Summary: error in rc.sysinit
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-14 17:56 UTC by Gerald Teschl
Modified: 2014-03-17 02:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 17:58:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2001-03-14 17:56:01 UTC
Here is another one. Looks like however, made these changes needs
a brush up in bash programming;-)


--- rc.sysinit.orig     Wed Mar 14 19:54:00 2001
+++ rc.sysinit  Wed Mar 14 19:54:47 2001
@@ -421,7 +421,7 @@
        modprobe md >/dev/null 2>&1
 fi
 
-if [ -f /proc/mdstat -f /etc/raidtab ]; then
+if [ -f /proc/mdstat -a -f /etc/raidtab ]; then
        echo -n $"Starting up RAID devices: "
 
        rc=0

Comment 1 Bill Nottingham 2001-03-14 17:58:05 UTC
Also fixed in 5.77-1. This is what happens when people build CVS without
actually checking it. :)


Note You need to log in before you can comment on or make changes to this bug.