Bug 317961 - NAMELEN too short in sgml stylesheet
NAMELEN too short in sgml stylesheet
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: docbook-dtds (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On: 159382
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 05:01 EDT by Tim Waugh
Modified: 2010-02-22 07:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-22 07:40:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2007-10-04 05:01:56 EDT
+++ This bug was initially created as a clone of Bug #159382 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4

Description of problem:
The various DocBook DTDs set a NAMELEN constant that is too short for many
purposes It is 44 now since years, and it should be set to a higher value; such
as 256.

If you grep NAMELEN `find /usr/share/sgml -name "*"` and change all "44" to
something larger it will fix the problem. 

Version-Release number of selected component (if applicable):
docbook-dtds-1.0-25

How reproducible:
Always

Steps to Reproduce:
1. Try using a name field larger than 44 in an sgml file.
2.
3.
  

Additional info:

-- Additional comment from devrim@gunduz.org on 2005-06-02 05:33 EST --
There is also another bug info for RH 7.1, reported by Havoc Pennington:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=36058

-- Additional comment from twaugh@redhat.com on 2005-06-02 09:07 EST --
Fixed in Fedora development, and so the next full release of Red Hat Enterprise
Linux will pick up the change.  I don't think this problem warrants an updated
package.

-- Additional comment from devrim@gunduz.org on 2005-06-02 09:14 EST --
There are many apps around that is experiencing problems with the NAMELEN issue,
like Slony-I: http://www.slony.info.

It's really not hard to keep it up with Fedora Core, but playing with RHEL is
not nice. As an RPM developer, I manually bump up the NAMELEN values, but I
don't think that all users can do this.

BTW, are you planinng a backpatch to FC 3?


-- Additional comment from devrim@gunduz.org on 2005-06-02 09:15 EST --
(In reply to comment #2)
> Fixed in Fedora development, and so the next full release of Red Hat Enterprise
> Linux will pick up the change.  I don't think this problem warrants an updated
> package.

There are many apps around that is experiencing problems with the NAMELEN issue,
like Slony-I: http://www.slony.info.

It's really not hard to keep it up with Fedora Core, but playing with RHEL is
not nice. As an RPM developer, I manually bump up the NAMELEN values, but I
don't think that all users can do this.

So, we *really* need an updated package. This *bug* exists since 7.1, so we
deserve an update.

BTW, are you planinng a backpatch to FC 3?

-- Additional comment from bod@optus.net on 2005-10-12 22:09 EST --
The 1.0-27 package still has "NAMELEN 44".  You need to change the regex used in
the substitution (sed doesn't match WS with \s).  Something like this works:

  # Increase NAMELEN (bug #36058, bug #159382).
  sed -e's,\(NAMELEN[ \t]\+\)44\>$,\1256,' -i.namelen */docbook.dcl

-- Additional comment from bod@optus.net on 2005-10-12 22:12 EST --
Ooop, drop the '$'...

-- Additional comment from twaugh@redhat.com on 2005-10-13 04:32 EST --
Sed certainly does match WS with \s -- and you are right that the $ was causing
the problem.  There is whitespace at the end of the line in the original file(!).

Thanks, fixed.

-- Additional comment from botsch@cnf.cornell.edu on 2007-10-03 15:06 EST --
Hi, guys. Stuff such as slony can't be built on rhel4 due to this issue. Please
fix in RHEL4. Thanks.
Comment 1 RHEL Product and Program Management 2008-02-01 14:02:02 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Note You need to log in before you can comment on or make changes to this bug.