Bug 317991 - offlineimap sometimes crash on SMP machine
offlineimap sometimes crash on SMP machine
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: offlineimap (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Till Maas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 05:57 EDT by Adam Tkac
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 10:29:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback from 5.99.4-1.fc9 (900 bytes, text/plain)
2007-11-01 04:30 EDT, Adam Tkac
no flags Details

  None (edit)
Description Adam Tkac 2007-10-04 05:57:54 EDT
Description of problem:
offlineimap sometimes crash on my dual core machine

Version-Release number of selected component (if applicable):
offlineimap-5.99.2-1.fc8

How reproducible:
often

Steps to Reproduce:
1. start offlineimap
2. see traceback
  
Actual results:
traceback

Expected results:
sync-ed mailforder

Additional info:
Thread 'InputHandler loop' terminated with exception:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/offlineimap/threadutil.py", line 153,
in run
    Thread.run(self)
  File "/usr/lib/python2.5/threading.py", line 440, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.5/site-packages/offlineimap/ui/Curses.py", line 263, in
bgreaderloop
    ch = s.c.stdscr.getch()
AttributeError: CursesUtil instance has no attribute 'stdscr'


No debug messages were logged for InputHandler loop.

This problem doesn't occur on my one-processor machine. Let me know if you need
more debuginfo
Comment 1 Till Maas 2007-10-10 03:21:56 EDT
Do you have this problem with offlineimap from F7, too? It is:
offlineimap-4.0.16-3.fc7
Comment 2 Adam Tkac 2007-10-10 05:48:16 EDT
I'm not sure if problem is same. offlinemap also sometimes crashes. Core dump is
on http://people.redhat.com/atkac/core.tar.bz2
Comment 3 Till Maas 2007-10-20 04:23:24 EDT
There has been a new release of offlineimap, when branching in cvs finished, I
will build it for the new rawhide, maybe this will work then. Did you test,
whether offlineimap-4.0.16-3.fc7 works on your dual core machine?
Comment 4 Adam Tkac 2007-10-22 04:40:19 EDT
(In reply to comment #3)
> There has been a new release of offlineimap, when branching in cvs finished, I
> will build it for the new rawhide, maybe this will work then. Did you test,
> whether offlineimap-4.0.16-3.fc7 works on your dual core machine?

Yes, I tested it. It also crashed (link specified in comment #2 points to core
dump). Let me know when new package will be avaliable for testing.
Comment 5 Till Maas 2007-10-22 05:50:43 EDT
Here is the new build: offlineimap-5.99.4-1.fc9

http://koji.fedoraproject.org/koji/buildinfo?buildID=21858
Comment 6 Adam Tkac 2007-11-01 04:30:11 EDT
Created attachment 245291 [details]
traceback from 5.99.4-1.fc9

I still have problems. See attached traceback
Comment 7 Till Maas 2008-03-04 04:39:59 EST
Sorry for the long silence, can you please try it with offlineimap-5.99.6-1.fc9?

https://koji.fedoraproject.org/koji/taskinfo?taskID=490023
Comment 8 Adam Tkac 2008-03-12 10:29:34 EDT
Yes, it looks better now. No traceback since update to 5.99.6. Thanks for your
help, closing

Note You need to log in before you can comment on or make changes to this bug.