Bug 3181 - nmh doesn't have /etc/smrsh link
nmh doesn't have /etc/smrsh link
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nmh (Show other bugs)
6.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-31 14:09 EDT by omega
Modified: 2015-01-07 18:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-01 15:56:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description omega 1999-05-31 14:09:27 EDT
I recently upgraded my server from 4.2 to 6.0, and since
then have been unable to get mail.  It turns out that slocal
(which I use to filter my mail) wasn't allowed to be run
from sendmail.  Finally figured out that a link to
/usr/lib/nmh/slocal is necessary in /etc/smrsh in order to
allow it to function.

IMHO this link should be standard, since slocal is a
*standard* mail handling program.  Since smrsh functionality
is a new thing since 4.2, it seems to me that existing
functionality (standard functionality at that) shouldn't be
broken.

%postinstall
ln -sf /usr/lib/nmh/slocal /etc/smrsh/slocal

%postuninstall
rm -f /etc/smrsh/slocal
Comment 1 Jeff Johnson 1999-06-01 15:56:59 EDT
Fixed (by createing /etc/smrsh/slocal symlink) in nmh-1.0-2.

Note You need to log in before you can comment on or make changes to this bug.