This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 31816 - upgrade to 2.4.2-0.1.28 breaks dhcp setting default router
upgrade to 2.4.2-0.1.28 breaks dhcp setting default router
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-14 21:08 EST by James Manning
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-15 13:29:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Manning 2001-03-14 21:08:09 EST
upgrading from 2.4.2-0.1.16 to 2.4.2-0.1.28 breaks the setting of the
default route from eth0, which is dhcp from a cable modem.  Going back
to 0.1.16 and it works again.  All other route table entries are fine,
just the default route isn't getting set.
Comment 1 Bill Nottingham 2001-03-14 21:18:17 EST
Weird. Are you sure you didn't install initscripts-5.75 in the interim? :)
Comment 2 James Manning 2001-03-14 21:28:55 EST
which is why i said booting back to 0.1.16 gets it working again :)

initscripts-5.00-1 is what's installed... did 0.1.28 need a dep
that it was missing?
Comment 3 Bill Nottingham 2001-03-14 22:25:27 EST
No, it's just that that version (5.75-1) of initscripts has the
exact same effect. :)
Comment 4 Michael K. Johnson 2001-03-15 12:38:59 EST
What ethernet card?
Comment 5 James Manning 2001-03-15 12:43:10 EST
Jeremy Katz suggested upgrading pump, but since it's largely still a
RH6.2 system, I can't, and it doesn't build from src.rpm... but anyway.

jmm@bp6:/home/jmm> rpm -q pump
pump-0.7.8-1

the dhcp ethernet card is the tulip driver, FA310TX card

00:09.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
        Subsystem: Netgear FA310TX
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at c400 [size=256]
        Memory at d900b000 (32-bit, non-prefetchable) [size=256]
        Expansion ROM at <unassigned> [disabled] [size=256K]
Comment 6 Michael K. Johnson 2001-03-15 13:11:17 EST
Arjan, any recent changes to tulip?
Comment 7 Arjan van de Ven 2001-03-15 13:29:24 EST
No. 0.1.28 has 2 possible bad guys:
1) the updated zerocopy patch
2) slab poison
Comment 8 James Manning 2001-11-26 02:09:01 EST
this has been working for awhile now - closing

Note You need to log in before you can comment on or make changes to this bug.