Bug 318181 - cryptix doesn't compile with newest jdk (patch included)
cryptix doesn't compile with newest jdk (patch included)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cryptix (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matt Wringe
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 08:51 EDT by Oliver Falk
Modified: 2008-07-30 16:02 EDT (History)
0 users

See Also:
Fixed In Version: 3.2.0-9jpp.3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 16:02:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Replace enum with enum1 (1.82 KB, patch)
2007-10-04 08:51 EDT, Oliver Falk
no flags Details | Diff

  None (edit)
Description Oliver Falk 2007-10-04 08:51:25 EDT
Since enum is now reserved. cryptix does no longer compile in rawhide. I have
made a patch replacing enum with enum1 in IJCE.java. Ugly hack, but works.

Patch for spec (without corresponing cl entries):

RCS file: /cvs/pkgs/devel/cryptix/cryptix.spec,v
retrieving revision 1.10
diff -r1.10 cryptix.spec
48a49
> Patch0:               cryptix-3.2.0.jdk1.5fix.patch
84a86,87
> %patch0 -p1 -b .jdk1.5fix
Comment 1 Oliver Falk 2007-10-04 08:51:25 EDT
Created attachment 215761 [details]
Replace enum with enum1
Comment 2 Oliver Falk 2007-10-29 11:18:02 EDT
ping
Comment 3 Matt Wringe 2007-10-30 09:51:49 EDT
hmm, I have your patch applied in my workspace, I guess I just didn't upload it.
I am going to retest the patch and then submit it today.

Sorry about the wait.
Comment 4 Oliver Falk 2007-10-30 09:57:08 EDT
No problem. I just want to make sure that if I encounter a rebuild problem, that
it gets fixed, so that others don't have to worry about the same problem again...
Comment 5 Fedora Update System 2007-11-08 00:59:36 EST
cryptix-3.2.0-9jpp.3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cryptix'
Comment 6 Fedora Update System 2008-07-30 16:02:54 EDT
cryptix-3.2.0-9jpp.3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.