Bug 318211 - [hts-5.1.1][ia64-xen, x86_64][cdrom][RHEL5.1.1] - cdrom testing FAIL
[hts-5.1.1][ia64-xen, x86_64][cdrom][RHEL5.1.1] - cdrom testing FAIL
Status: CLOSED DUPLICATE of bug 435877
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
ia64 Linux
low Severity low
: ---
: ---
Assigned To: YangKun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 09:15 EDT by Satyabrata Maitra
Modified: 2008-07-16 17:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 12:13:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL5.1 - results.xml for ia64-xen system with 20070927.0 tree (384.00 KB, text/xml)
2007-10-08 03:28 EDT, Satyabrata Maitra
no flags Details
results.xml (384.00 KB, text/xml)
2007-10-09 04:56 EDT, YangKun
no flags Details
cdrom and other .xml file (2.01 MB, application/x-tar)
2007-10-12 07:43 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2007-10-04 09:15:51 EDT
Description of problem:
cdrom testing failing in both the archs - ia64-xen and x86_64 in RHEL5.1 but
more over that, for both the cases the output.log file is just empty showing.
Reason is unknown. Is it itself a bug? please inform.

Version-Release number of selected component (if applicable):
hts-5.1.1
tree followed :
ia64-xen - 20070927.0
x86_64 - 20070927.nightly

How reproducible:
Tested Once

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Its FAIL

Expected results:
It should PASS

Additional info:
Comment 1 Greg Nichols 2007-10-04 10:16:26 EDT
Yes, it's a bug.  

Please supply /var/hts/results.xml

Comment 2 Satyabrata Maitra 2007-10-08 03:28:35 EDT
Created attachment 219061 [details]
RHEL5.1 - results.xml for ia64-xen system with 20070927.0 tree

For x86_64 arch, the results.xml file itself is showing empty. Only could
provide ia64-xen results.xml file in this case.
Comment 3 YangKun 2007-10-08 05:38:54 EDT
Hi Satyabrata,

I can not download the results.xml file you attached above, I met following
error while I'm tring to download:
    --------------------------------------------------------------
    XML Parsing Error: no element found
    Location: https://bugzilla.redhat.com/attachment.cgi?id=219061
    Line Number 7632, Column 7:Gettin
    ------^
    --------------------------------------------------------------

could you please attach it again or send it to me directly ? My email addr is
ykun@redhat.com

Thanks very much!
-YK
Comment 4 Satyabrata Maitra 2007-10-09 01:21:53 EDT
Hello YK

I just sent it to you. Please check your mail. :)

Thanks
Satya
Comment 5 YangKun 2007-10-09 04:56:59 EDT
Created attachment 220911 [details]
results.xml
Comment 6 YangKun 2007-10-09 05:34:51 EDT
Hi Satyabrata,

I checked the result log, the error is:
    -------------------------------------------------------------
    Please insert a data CD disk into hdc and then press ENTER to continue !
      +++ Start testing CD-ROM ... 


      +++ Error: Mount media failed !


      Please check if the disk you inserted is good media,
      or you forget to insert the disk ?


      +++ CD/CD-R/CD-RW test failed.
    -------------------------------------------------------------

seem no cdrom disk been provided. are you testing on a remote machine ? If so,
you need someone(who is near to the test machine) to help you insert CD/DVD
disks into the cdrom drive as the test asked.

Please notice the CDROM test is an "interactive" test, it will ask user to
insert or remove testing media(CD/DVD/CD-R disks etc.)

Could you please verify if a proper(also a good) media/disk is inserted and then
re-test ?

Please let me know if this issue still exists.

Thanks very much!
-YK
Comment 7 Satyabrata Maitra 2007-10-12 07:39:39 EDT
YK

I also think so! Yes, I did it remotely! And naturally, no media entered!
Currently, I tested it on my own test system, arch- x86_64, with hts-5.1-3. And
its still FAIL. I am attaching its necessary results file below. Please see
once. Btw, I cound not test it on ia64, because, i do not have any ia64 system
with me and with physical access! Lets see, if i can manage one.
Comment 8 Satyabrata Maitra 2007-10-12 07:43:15 EDT
Created attachment 225411 [details]
cdrom and other .xml file
Comment 9 Greg Nichols 2007-10-22 10:30:57 EDT
Here's the traceback from the above attachment:

Start to compare data, this may take some time, please be patient ... 
Traceback (most recent call last):
  File "./cdrom.py", line 708, in ?
    returnValue = test.do(sys.argv)
  File "/usr/share/hts/lib/hts/test.py", line 226, in do
    return self.run()
  File "./cdrom.py", line 618, in run
    returnValue = self.testCDRW(cdromDevice)
  File "./cdrom.py", line 487, in testCDRW
    returnValue = self.rewriter("cdrom",cdromDevice)
  File "./cdrom.py", line 423, in rewriter
    returnValue = self.writer(deviceType,cdromDevice)
  File "./cdrom.py", line 393, in writer
    if self.cmpTree(fileDir,"media"):
  File "./cdrom.py", line 80, in cmpTree
    if filecmp.cmp(file1,file2):
  File "/usr/lib64/python2.4/filecmp.py", line 49, in cmp
    s2 = _sig(os.stat(f2))
OSError: [Errno 2] No such file or directory: 'media/vimtutor'
...finished running ./cdrom.py, exit code=1

Comment 10 YangKun 2007-10-25 10:38:23 EDT
Hi Satyabrata,

The error shows one file(/usr/bin/vimtutor) is not written to the cd-rw disc,
have you done some package install/un-install while the CDROM test was running ?

Could you please confirm if the file "/usr/bin/vimtutor" exists on your test
machine and then re-run the CDROM test again ? And please do not run other
commands or programs(especially not to install/un-install software) while the
CDROM test is running.

Thanks
-YK

Comment 11 Greg Nichols 2008-03-06 12:13:29 EST

*** This bug has been marked as a duplicate of 435877 ***

Note You need to log in before you can comment on or make changes to this bug.