Bug 318231 - php failed to start because of missing aspell
php failed to start because of missing aspell
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-04 09:20 EDT by Ingo Schaefer
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-05 12:12:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ingo Schaefer 2007-10-04 09:20:23 EDT
Description of problem:
after upgrade to fedora 7 the apache httpd was not working, because of a missing

Version-Release number of selected component (if applicable):

How reproducible:
tried once

Steps to Reproduce:
1. install fc6
2. (deinstall aspell - not sure about this)
3. upgrade to fedora 7
4. try to start apache httpd
Actual results:
apache did not start, because php lib hat unresolved dependency

Expected results:
apache should start, php should not depend on aspell or aspell should be
installed during upgrade

Additional info:
Comment 1 Joe Orton 2007-10-05 06:36:53 EDT
Was this an anaconda update?  Did you --force the removal of aspell before

Please attach the /root/anaconda.log.
Comment 2 Ingo Schaefer 2007-10-05 11:04:35 EDT
Sorry, I mixed this up with another installation.

This error was on a fresh installed fedora 7 box, where I tried to remove some
packages via the "pirut" software management application and I did not force
removal of the packages.

So at the installation all deps have been resolved and aspell has been
installed. After reboot I decided to clean up a bit and removed aspell without
forcing it, after that the httpd did not start, because the php module crashed
without aspell.
Comment 3 Joe Orton 2007-10-05 11:17:27 EDT
Without a precise reproduction case there isn't much we can do here.

Can you restore the original system state, then reproduce by doing:

rpm -qa > before
# some action
rpm -qa > after

and show "php" is still installed by aspell is missing.
Comment 4 Ingo Schaefer 2007-10-05 11:33:13 EDT
Sorry, it can not be reproduced.

I tried:
rpm -qa ...
run pirut, change to "list" tab, deselect aspell and aspell-en and click on "apply"

On Sep 26th, this has been successful and aspell was deinstalled, but php remained.

Today, pirut complained about missing deps and failed to deinstall aspell and
aspell-en without removing php and php-cli

Don't know, what it was, but I had this situation - my log files prove this to me.
Comment 5 Joe Orton 2007-10-05 12:12:37 EDT
Without a reproduction case unfortunately there is little more that can be done.

Note You need to log in before you can comment on or make changes to this bug.