Bug 318311 - pirut cs.po breaks pirut, pup, and puplet under cs_CZ.UTF-8 locale
pirut cs.po breaks pirut, pup, and puplet under cs_CZ.UTF-8 locale
Status: CLOSED CURRENTRELEASE
Product: Fedora Localization
Classification: Fedora
Component: Other language (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Matěj Cepl
A S Alam
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 10:49 EDT by Matěj Cepl
Modified: 2013-07-02 20:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: 26.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-26 09:19:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against cs.po (574 bytes, patch)
2007-10-04 10:49 EDT, Matěj Cepl
no flags Details | Diff

  None (edit)
Description Matěj Cepl 2007-10-04 10:49:45 EDT
Description of problem:
When starting any of {pup,puplet,pirut} it breaks with the error indicating
broken Plural-Forms. Which is correct, because apparently the string got broken
somehow and it reads

"Plural-Forms:  nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%"

When fixing to the form prescribed for the Czech language in gettext(info):

"Plural-Forms: nplurals=3;" 
" plural=n%100/10==1 ? 2 : n%10==1 ? 0 : (n+9)%10>3 ? 2 : 1;\n"

everything works fine. Patch is attached.
Comment 1 Matěj Cepl 2007-10-04 10:49:45 EDT
Created attachment 215881 [details]
Patch against cs.po
Comment 2 Matěj Cepl 2007-10-04 18:22:37 EDT
It is probably fixed in Rawhide pirut.
Comment 3 Adam Pribyl 2007-10-05 05:17:34 EDT
Yes, M. Trmac probably fixed this 26.9.
Comment 4 Adam Pribyl 2007-10-06 13:54:24 EDT
Please close the bug - the problem is fixed in rawhide, or does it need any
further attention?
Comment 5 Matěj Cepl 2007-10-07 16:22:39 EDT
I am not sure how does it work with Localization stuff, but does pirut
maintainer knows about this, and could he please put this into next update for
Fedora 7. It really sucks that currently pirut doesn't work at all on F7 with
the Czech locale.
Comment 6 Adam Pribyl 2007-10-08 10:11:54 EDT
I was not aware of that this also affects F7, I thought its only F8 problem. We
should report a bug against pirut then.
Comment 7 Matěj Cepl 2007-10-23 08:06:58 EDT
(In reply to comment #6)
> I was not aware of that this also affects F7, I thought its only F8 problem. We
> should report a bug against pirut then.

Did it happen or should I file the bug?
Comment 8 Adam Pribyl 2007-10-23 10:21:19 EDT
I have F7 installed and I do not see this problem to occure. Are you
experiencing this problem? If yes then please report it.
Comment 9 Matěj Cepl 2007-10-23 11:29:43 EDT
OK, then close the bug. Unfortunately I don't have any F7 system anymore (which
is shame, I should have).
Comment 10 Dimitris Glezos 2008-01-26 09:19:29 EST
From what I understand this is now fixed. If F7 pirut needs an update, a bug
report should be opened against it.

Closing bug report.

Note You need to log in before you can comment on or make changes to this bug.