Bug 31836 - dhcpcd runs twice for each interface
dhcpcd runs twice for each interface
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-14 22:41 EST by Reece Dike
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-25 23:52:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reece Dike 2001-03-14 22:41:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.12-01 i686)


When booting dhcpcd is run twice for each network card. If I run
'/etc/rc.d/init.d/network stop' then manually kill the remaining task, then
run '/etc/rc.d/init.d/network start' only one dhcpcd task will appear for
each interface card.  I ran 'chmod a-x /sbin/pump' to get /sbin/ifup to use
dhcpcd. Here is the output from 'ps auwx' after a reboot.
[root@new /root]# ps auwx|grep dhcpcd
root       452  0.0  0.1   412  156 ?        S    21:18   0:00 /sbin/dhcpcd
eth0
root       456  0.0  0.1   424  212 ?        S    21:18   0:00 /sbin/dhcpcd
eth0
root       594  0.0  0.1   412  156 ?        S    21:18   0:00 /sbin/dhcpcd
eth1
root       600  0.0  0.1   424  212 ?        S    21:18   0:00 /sbin/dhcpcd
eth1
root      1039  0.0  0.4  1596  588 pts/0    S    21:24   0:00 grep dhcpcd


Here is the section from /var/log/messages
Mar 14 21:18:37 new sysctl: net.ipv4.ip_forward = 0
Mar 14 21:18:37 new sysctl: net.ipv4.conf.all.rp_filter = 1
Mar 14 21:18:37 new sysctl: kernel.sysrq = 0
Mar 14 21:18:37 new network: Setting network parameters:  succeeded
Mar 14 21:18:37 new ifup: ifup called
Mar 14 21:18:37 new ifup: ipcalc: netmask expected
Mar 14 21:18:37 new network: Bringing up interface lo:  succeeded
Mar 14 21:18:38 new ifup: ifup called
Mar 14 21:18:38 new ifup: Determining IP information for eth0...
Mar 14 21:18:38 new /etc/hotplug/net.agent: register event not handled
Mar 14 21:18:38 new ifup:  done.
Mar 14 21:18:38 new dhcpcd[449]: dhcpConfig: ioctl SIOCADDRT: File exists
Mar 14 21:18:38 new dhcpcd[451]: error executing
"/etc/sysconfig/network-scripts/ifup-post ifcfg-eth0": Bad address
Mar 14 21:18:38 new network: Bringing up interface eth0:  succeeded
Mar 14 21:18:38 new ifup: ifup called
Mar 14 21:18:39 new /etc/hotplug/net.agent: register event not handled
Mar 14 21:18:39 new ifup: Determining IP information for eth1...
Mar 14 21:18:44 new ifup:  done.
Mar 14 21:18:44 new dhcpcd[591]: dhcpConfig: ioctl SIOCADDRT: File exists
Mar 14 21:18:44 new dhcpcd[593]: error executing
"/etc/sysconfig/network-scripts/ifup-post ifcfg-eth1": Bad address
Mar 14 21:18:44 new network: Bringing up interface eth1:  succeeded
Mar 14 21:18:49 new xinetd: xinetd startup succeeded



Reproducible: Always
Steps to Reproduce:
1. Make /sbin/pump nonexecutable so ifup calls dhcpcd 
2. reboot system.
3.
	

Actual Results:  Had two copies of dhcpcd running for each interface card.
Only happens during boot.  

Expected Results:  Only one copy of dhcpcd should be running for each
interface card.

The problem only occurs during boot.  I added '/bin/echo "ifup called"' to
the beginning of /sbin/ifup to see if it is being called twice. As you can
see from /var/log/messages above it is only called once for each interface.
Here are the entries from modules.conf
alias eth0 tulip
alias eth1 3c59x

System is an 800Mhz Duron.
I did an everything install of wolverine.
Comment 1 Bill Nottingham 2001-03-15 17:40:37 EST
I just tried this on the current tree and couldn't reproduce this.
You may want to try the latest hotplug and initscripts RPMs in
rawhide.

There is a bug fix releated to the 'bad address' messages in
dhcpcd-1.3.18pl8-10.
Comment 2 Reece Dike 2001-03-25 23:39:02 EST
The dhcpcd is still running twice on bootup.

I down loaded dhcpcd-1.3.18pl8-10 from the rawhide tree at ftp.redhat.com and
installed it on my system.  It did remove the bad address bug, but I still have
the problem of dhcpcd showing up twice for one interface.  If I run
'/etc/rc.d/init.d/network stop', only one of the two instances goes away. I can
kill the remaining instance with a kill command. I then run
'/etc/rc.d/init.d/network  start' and there is only one instance of dhcpcd
running.  Here is a 'ps auwwx' run just after booting and ssh into the box.
Notice processes 452 and 484.

USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
root         1  5.5  0.4  1344  532 ?        S    22:42   0:04 init [3]
root         2  0.0  0.0     0    0 ?        SW   22:42   0:00 [keventd]
root         3  0.0  0.0     0    0 ?        SW   22:42   0:00 [kapm-idled]
root         4  0.0  0.0     0    0 ?        SW   22:42   0:00 [kswapd]
root         5  0.0  0.0     0    0 ?        SW   22:42   0:00 [kreclaimd]
root         6  0.0  0.0     0    0 ?        SW   22:42   0:00 [bdflush]
root         7  0.0  0.0     0    0 ?        SW   22:42   0:00 [kupdate]
root         8  0.0  0.0     0    0 ?        SW<  22:42   0:00 [mdrecoveryd]
root        79  0.0  0.0     0    0 ?        SW   22:43   0:00 [khubd]
root       452  0.0  0.1   412  160 ?        S    22:43   0:00 /sbin/dhcpcd eth0
root       484  0.0  0.1   424  212 ?        S    22:43   0:00 /sbin/dhcpcd eth0
root       732  0.1  0.4  1404  616 ?        S    22:43   0:00 syslogd -m 0
root       765  0.2  0.8  1968 1100 ?        S    22:43   0:00 klogd -2
root       821  0.0  0.4  1328  524 ?        S    22:43   0:00 /usr/sbin/apmd -p
10 -w 5 -W -P /etc/sysconfig/apm-scripts/apmscript
daemon     835  0.0  0.4  1376  564 ?        S    22:43   0:00 /usr/sbin/atd
root       846  0.2  0.9  2524 1164 ?        S    22:43   0:00 /usr/sbin/sshd
root       865  0.0  0.7  2204 1004 ?        S    22:43   0:00 xinetd -stayalive
-reuse -pidfile /var/run/xinetd.pid
root       884  0.0  0.4  1384  552 ttyS0    S    22:43   0:00 gpm -t ms
root       896  0.0  0.5  1524  684 ?        S    22:43   0:00 crond
xfs        966  0.2  3.1  5280 4008 ?        S    22:43   0:00 xfs -droppriv
-daemon
root       991  0.0  0.4  1512  608 ?        S    22:43   0:00 rhnsd --interval
120
root      1014  0.0  0.3  1316  432 tty1     S    22:43   0:00 /sbin/mingetty
tty1
root      1015  0.0  0.3  1316  432 tty2     S    22:43   0:00 /sbin/mingetty
tty2
root      1016  0.0  0.3  1316  432 tty3     S    22:43   0:00 /sbin/mingetty
tty3
root      1017  0.0  0.3  1316  432 tty4     S    22:43   0:00 /sbin/mingetty
tty4
root      1018  0.0  0.3  1316  432 tty5     S    22:43   0:00 /sbin/mingetty
tty5
root      1019  0.0  0.3  1316  432 tty6     S    22:43   0:00 /sbin/mingetty
tty6
root      1022  0.1  1.4  3364 1836 ?        S    22:43   0:00 /usr/sbin/sshd
root      1023  0.5  1.0  2380 1364 pts/0    S    22:44   0:00 -bash
root      1059  0.0  0.5  2572  756 pts/0    R    22:44   0:00 ps auwwx
Comment 3 Reece Dike 2001-03-25 23:52:11 EST
Sorry, about the previous post. I did not download the latest hotplug or
initscripts.  After doing that the problem with dhcpcd running twice has
disappeared.  You can close the bug report.

Thanks for the help
Reece Dike
reece@erd3.com

Note You need to log in before you can comment on or make changes to this bug.