Bug 318431 - amarok: cannot require HelixPlayer on alpha, add to the list of arches...
amarok: cannot require HelixPlayer on alpha, add to the list of arches...
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
alpha Linux
low Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-04 11:04 EDT by Oliver Falk
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-06 11:06:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-10-04 11:04:48 EDT
Please add alpha to the list of arches where HelixPlayer cannot be used.

Search for sparc in the spec and add alpha to the list. There are three lines -
sorry to lazy to provide a patch for that now.

Maybe you better add some no_helix_arches define at the top, so you don't need
to change it in 3 places every time :-)
Comment 1 Rex Dieter 2007-10-05 11:31:46 EDT
fwiw, HelixPlayer includes only:
ExcludeArch:    ppc64 x86_64 s390 s390x ia64

perhaps HelixPlayer/amarok should both start using whitelists of known-working
archs, instead of blacklists.

So, HelixPlayer works on what?  i386, ppc ?  anything else?
Comment 2 Rex Dieter 2007-10-05 11:35:38 EDT
I've got a simple specfile solution here, pending confirmation of archs.
Comment 3 Aurelien Bompard 2007-10-06 11:06:19 EDT
IIRC ExclusiveArch is discouraged, so I just added alpha to the list (this
should not change too frequently so I didn't use defines)
I've also added alpha (and sparc and sparc64) to HelixPlayer's specfile.
Thanks, it should be fixed in 1.4.7-6 (rawhide)

Note You need to log in before you can comment on or make changes to this bug.