Bug 31846 - screen blanks using right mousebutton with openmotif
screen blanks using right mousebutton with openmotif
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-15 06:39 EST by Jan Kees
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 08:10:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's a running log (The X-server never crashes after a blank screen). (19.70 KB, text/plain)
2001-07-17 07:28 EDT, Jan Kees
no flags Details

  None (edit)
Description Jan Kees 2001-03-15 06:39:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14smp i686)


When I click the right mouse button in a program that uses openmotif such
as nedit-5.1.1-4.i386.rpm the screen blanks. When I then move the pointer a
little bit the screen comes back up again and I can see the menu wich is
supposed to be there and use it. This only happens with the sawfish window
manager and not with others (like enlightenment).
Some info:
-RedHat 7.0 with kernel 2.2.17-14smp
-librep-0.13.3-1.i386.rpm
-rep-gtk-0.15-3.i386.rpm
-rep-gtk-gnome-0.15-3.i386.rpm
-rep-gtk-libglade-0.15-3.i386.rpm
-sawfish-0.36-5.i386.rpm
-sawfish-themer-0.36-5.i386.rpm

Reproducible: Always
Steps to Reproduce:
1. open nedit
2. click right mouse button
3.
	

Actual Results:  screen blanks

Expected Results:  show the menu under the right mouse button
Comment 1 Havoc Pennington 2001-07-12 14:48:30 EDT
Works fine for me, what do you mean "the screen blanks"? Is your entire monitor
black? Or just nedit? Maybe an X bug...
Comment 2 Jan Kees 2001-07-13 04:12:53 EDT
The entire monitor is black, but as I said before it comes back up again as I
move the pointer when holding the right mouse button. It happens with both a
nvidia TNT2 and with a Matrox Millenium II graphical adapter.
Comment 3 Havoc Pennington 2001-07-13 10:26:12 EDT
Mike have you ever heard of this?

I see no way Sawfish could cause this without an X bug...
Comment 4 Mike A. Harris 2001-07-13 15:47:10 EDT
Yes, I have heard of something at least similar, and it is likely a
Motif app too.  I'll hunt it down...

Bug #46645 sounds very similar.  Check it out and let me know what you
think.  If it sounds like an X bug to you, which it does sound like to
me possibly, then reassign to X.

TO original poster, can you please attach to the bug report using the
link below a copy of your X server log?  From after a crash/hang/blankout
if possible, if not just a running log.
Comment 5 Havoc Pennington 2001-07-13 16:07:12 EDT
I think this is a lot more likely to be an X bug than a sawfish bug, so 
moving to X.
Comment 6 Jan Kees 2001-07-17 07:28:09 EDT
Created attachment 23807 [details]
Here's a running log (The X-server never crashes after a blank screen).
Comment 7 Mike A. Harris 2002-03-10 21:12:25 EST
This seems to be fixed now in rawhide XFree86 4.2.0.

Note You need to log in before you can comment on or make changes to this bug.