Bug 3185 - ndbm.h headder file.....
ndbm.h headder file.....
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-31 21:34 EDT by cst97064
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-01 14:17:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cst97064 1999-05-31 21:34:17 EDT
The file has been moved from

/usr/include/

in RedHat 5.2 to

/usr/include/db1/

in redhat 6.0, found it while installing OpenSSL and ModSSl
Comment 1 Jeff Johnson 1999-06-01 14:17:59 EDT
The choice of which ndbm.h implicitly chooses which database
emulation to use. What used to be in /usr/include was the
gdbm ndbm.h, what is in /usr/include/db1 is the db1 emulation.

Since there is no way for Red Hat to choose one emulation over
another for all possible applications, there is no way that we can
supply /usr/include/ndbm.h.
Comment 2 smanes 1999-08-05 22:03:59 EDT
Then pick one!  You _have_ to have to set some kind of standard here,
if only for those folks compiling third-party software, like Perl and
its various companion libraries, which expects one. As it is now,
Redhat 6.0 is a MAJOR bottleneck for me as a professional Perl
developer.  I've lost two days' work trying to get Perl.
5.005.03 installed without success because of these (effectively)
broken DBM libraries.

Linking db1/ndbm.h to /usr/include/ndbm.h only increased the number of
test errors.

Note You need to log in before you can comment on or make changes to this bug.