Bug 318601 - starts with selected codec, but "Get Selected" button isn't sensitive
starts with selected codec, but "Get Selected" button isn't sensitive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: codeina (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-10-04 11:59 EDT by Jeremy Katz
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 09:14:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-10-04 11:59:02 EDT
The right codec is now selected by default, but I have to unchcek and recheck it
to actually be able to click "Get Selected"
Comment 1 Matthias Clasen 2007-10-09 10:11:03 EDT
Bastien says he fixed this, and it does indeed work as expected in my testing.
Comment 2 Jeremy Katz 2007-10-09 10:31:04 EDT
Works where?  I just tried with a rawhide live image of today, downloaded an mp3
from amazonmp3.com, loaded totem, it brings up codeina with mp3 decoder
selected.  But get selected is greyed out.
  http://katzj.fedorapeople.org/codeina-notselected.png 

Toggling the mp3 codec makes the button sensitive and I can continue on 
Comment 3 Matthias Clasen 2007-10-09 12:32:00 EDT
Hmm, you are right. A real mp3 in totem behaves differently

The synthetic test came up with only 'matching' codecs in codina, and the button
enabled.

When run from totem, it comes up with 'all available' codecs, and the button
disabled.
Comment 4 Bastien Nocera 2007-10-09 13:43:44 EDT
codeina-0.10.1-3 should help. Matthias debugged the problem as a quoting problem
when using the gst-plugins-install-helper script.
Comment 5 Matthias Clasen 2007-10-10 09:14:38 EDT
Works now in totem for me.
Comment 6 Andrej Kvasnica 2007-11-03 15:11:18 EDT
f8rc3 live cd
codeina version 0.10.1, release 5.fc8 (yum info codeina)

I downloaded wmv video,
codeina selected no matching codec,
I switched to 'all available'
there was Fluendo mp3 Audio Decoder checked
but [Get selected] button was disabled.
After unchecking and checking mp3 codec it enables the [Get selected] button.

Note You need to log in before you can comment on or make changes to this bug.