Bug 318861 - xserver broken for Radeon after 20071003 changes
xserver broken for Radeon after 20071003 changes
Status: CLOSED DUPLICATE of bug 318731
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 13:46 EDT by Michal Jaegermann
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 22:13:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf used in testing (823 bytes, text/plain)
2007-10-04 21:35 EDT, Michal Jaegermann
no flags Details
a log file from a run with functioning 1.3.0.0-24.fc8 server (48.25 KB, text/plain)
2007-10-04 21:37 EDT, Michal Jaegermann
no flags Details
log file from a run with 1.3.0.0-28.fc8 and the same conf file as above (30.63 KB, application/octet-stream)
2007-10-04 21:40 EDT, Michal Jaegermann
no flags Details
a log file from a run with 1.3.0.0-28.fc8 and no config file (50.74 KB, application/octet-stream)
2007-10-04 21:52 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-10-04 13:46:42 EDT
Description of problem:

After an update to xorg-x11-server-Xorg-1.3.0.0-27.fc8 on a machine
using "ATI Technologies Inc RV280 [Radeon 9200 PRO]",
"Chipset ATI Radeon 9250 5960 (AGP) found", X does not start anymore.
A black screen and a dead keyboard.  It is still possible to login
over a network, 'kill -9 ...' offending processes (without '-9' this
does not work), and recover.  An output from 'startx' ends up
with:
......
finished output detect: 0
finished output detect: 1
finished output detect: 2
finished all detect
before xf86InitialConfiguration
in RADEONProbeOutputModes

and that is it until "Killed" one gets after forcing a termination.
An expected message "after xf86InitialConfiguration" never shows up.
Updating to 1.3.0.0-28.fc8 does not change anything in the above
and X starts working again only after downgrading to
xorg-x11-server-Xorg-1.3.0.0-24.fc8.

Replacing xorg-x11-drv-ati and/or mesa libraries with older versions
does not seem to have any effects on the situation.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-27.fc8
xorg-x11-server-Xorg-1.3.0.0-28.fc8

How reproducible:
always
Comment 1 Michal Jaegermann 2007-10-04 14:27:00 EDT
xorg-x11-server-Xorg-1.3.0.0-26.fc8 from koji also does not work
for me in exactly the same way as 27 and 28.  There is no 25 so
24 is the last one operational.
Comment 2 Matěj Cepl 2007-10-04 18:41:43 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Michal Jaegermann 2007-10-04 21:35:42 EDT
Created attachment 216921 [details]
xorg.conf used in testing

This is xorg.conf produced by system-config-display and used in testing.
With the last correctly functioning xserver 1.3.0.0-24.fc8 this is
producing a display with a desired resolution and a clock, centered
in the middle of a monitor screen.  'xrandr' gives the following output:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1920 x 1200
VGA-0 connected 1024x768+0+0 (normal left inverted right) 0mm x 0mm
   1024x768	  85.0*+   75.0     70.1     60.0
   1920x1080	  60.0	   59.9
   1680x1050	  60.0	   59.9
   1600x1024	  60.2
   1400x1050	  60.0
   1280x1024	  60.0
   1440x900	  59.9
   1280x960	  60.0
   1360x768	  59.8	   60.0
   1280x800	  75.0	   70.0     60.0
   1152x864	  75.0	   75.0     70.0     60.0
   1280x768	  85.0	   75.0     70.0     60.0
   1280x720	  85.0	   75.0     70.0     60.0
   1152x768	  54.8
   832x624	  74.6
   800x600	  85.1	   72.2     75.0     60.3     56.2
   640x480	  85.0	   72.8     75.0     59.9
   720x400	  85.0
   640x400	  85.1
   640x350	  85.1
DVI-0 disconnected (normal left inverted right)
S-video disconnected (normal left inverted right)
Comment 4 Michal Jaegermann 2007-10-04 21:37:33 EDT
Created attachment 216931 [details]
a log file from a run with functioning 1.3.0.0-24.fc8 server
Comment 5 Michal Jaegermann 2007-10-04 21:40:53 EDT
Created attachment 216941 [details]
log file from a run with 1.3.0.0-28.fc8 and the same conf file as above

Such run results in a black screen and a dead keyboard.
Comment 6 Dave Airlie 2007-10-04 21:44:25 EDT
this sounds like the X server is looping in the mode code.. please remove the
modes line from your xorg.conf and see if it gets any further..

we need to investigate the fix if that works for you...
Comment 7 Michal Jaegermann 2007-10-04 21:52:25 EDT
Created attachment 216961 [details]
a log file from a run with 1.3.0.0-28.fc8 and no config file

When running without a config file with 1.3.0.0-28.fc8 I am indeed
getting a picture but it comes in a screwy 1360x768 resolution with
a bad refresh rate.  An output from xrandr looks like follows:

Screen 0: minimum 320 x 200, current 1360 x 768, maximum 1360 x 1200
VGA-0 connected 1360x768+0+0 (normal left inverted right x axis y axis) 0mm x
0mm
   1360x768	  59.8*    60.0
   1280x800	  60.0
   1152x864	  60.0
   1280x768	  60.0
   1280x720	  60.0
   1024x768	  60.0
   800x600	  60.3
   640x480	  59.9
DVI-0 disconnected (normal left inverted right x axis y axis)
S-video disconnected (normal left inverted right x axis y axis)

To make things more interesting although 'xrandr -s X', where X
is 0, 2, 3 or 4 does move '*' on xrandr output but there are no
visible effects on a screen.

After 'xrandr -s 5' resolution _visually_ does change to  1024x768
but a picture is positioned sharply to the left with a wide margin
on the right and a refresh rate is clearly out-to-lunch.
Comment 8 Michal Jaegermann 2007-10-04 22:10:12 EDT
Re comment #6:

After removing modes line from xorg.conf I can indeed start both with
1.3.0.0-24.fc8 and 1.3.0.0-28.fc8 but in both cases display comes
in 1360x768 resolution and with a constant very annoying flicker.
An output from xrandr for 1.3.0.0-28.fc8 looks in this case as follows:

Screen 0: minimum 320 x 200, current 1360 x 768, maximum 1920 x 1200
VGA-0 connected 1360x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080      60.0     59.9
   1680x1050      60.0     59.9
   1600x1024      60.2
   1400x1050      60.0
   1280x1024      60.0
   1440x900       59.9
   1280x960       60.0
   1360x768       59.8*    60.0
   1280x800       75.0     70.0     60.0
   1152x864       75.0     75.0     70.0     60.0
   1280x768       85.0     75.0     70.0     60.0
   1280x720       85.0     75.0     70.0     60.0
   1152x768       54.8
   1024x768       85.0     75.0     70.1     60.0
   832x624        74.6
   800x600        85.1     72.2     75.0     60.3     56.2
   640x480        85.0     72.8     75.0     59.9
   720x400        85.0
   640x400        85.1
   640x350        85.1
DVI-0 disconnected (normal left inverted right x axis y axis)
S-video disconnected (normal left inverted right x axis y axis)

Just for an extra fun 'xrandr -s 10' does switch to 1024x768
and 85 pixel clock, thus killing that flicker, but pictures
with 1.3.0.0-28.fc8 are still coming shifted to the left.
Comment 9 Dave Airlie 2007-10-04 22:13:11 EDT
okay so this sounds like 318731 territory.. thanks for the test..

*** This bug has been marked as a duplicate of 318731 ***

Note You need to log in before you can comment on or make changes to this bug.