This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 319071 - iwl3945 and 4965: Failed to read scan data : Resource temporarily unavailable
iwl3945 and 4965: Failed to read scan data : Resource temporarily unavailable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-10-04 15:04 EDT by Warren Togami
Modified: 2008-04-16 21:49 EDT (History)
13 users (show)

See Also:
Fixed In Version: 2.6.23.12-101.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 15:19:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-10-04 15:04:04 EDT
iwl3945 often gets into a state where it has no scan results.  iwlscan says:
wlan0     Failed to read scan data : Resource temporarily unavailable

Reloading the iwl3945 module allows it to scan again.  dcbw says this is a
driver issue.  It happens often enough that it is crippling to the user experience.

Thinkpad T60 x86_64
kernel-2.6.23-0.218.rc9.git1.fc8 
iwl3945-firmware-2.14.1.5-2
Comment 1 Warren Togami 2007-10-04 21:35:22 EDT
iwl4965 seems to be affected as well.

But surprise!  217 works while 218 doesn't.  Untagging 218 from rawhide so it
wont break our Test3 users.
Comment 2 John W. Linville 2007-10-05 09:44:15 EDT
Warren, is it only these two drivers?  Have you had a chance to try any other 
mac80211-based drivers, e.g. zd1211rw-mac80211, b43, rt73usb, etc?
Comment 3 Warren Togami 2007-10-05 10:08:03 EDT
I don't have hardware for anything else.
Comment 4 Jarod Wilson 2007-10-05 17:06:08 EDT
Ooh, I'm excited! Finally got around to poking b43 + latest network manager, and
for the first time ever, I'm actually able to get my laptop to connect to the
office wifi, stay connected, pass traffic, etc... Haven't yet seen any issues
with scanning, but haven't been paying attention that long.
Comment 5 Jarod Wilson 2007-10-09 11:43:18 EDT
So I was working from home yesterday, and brought up ye olde laptope in Linux,
connected to my wireless base station, and all was well for a little while...
Had a few things going on, then fired up a little yum upgrade action. A few
packages into downloading, my network connection suddenly died. The
NetworkManager doohickey in the menu bar disappeared, the interface no longer
had an IP address, and I couldn't get anything back restarting NetworkManager.
Turned out my wireless base station was also deep-sixed in the process. It was
still powered up, but had disappeared from radar -- couldn't even see it back
under OS X. After a power-cycle of the base station, all was well again, but I
stuck with working under OS X the rest of the day... :) (never seen anything
like this before, have had this laptop and base station for at least 2 years now).
Comment 6 Bill Nottingham 2007-10-09 11:49:02 EDT
FWIW, the behavior in comment #1 has been happening forever with iwl3945; I've
yet to see a version where it *didn't* happen. It goes into bozo mode more often:
- if I'm further from the AP
- if I close the lid (presumably changing the antenna characteristics)
Comment 7 John W. Linville 2007-10-16 13:56:06 EDT
Is this still a problem with current rawhide of fc8 kernels?
Comment 8 Warren Togami 2007-10-16 14:37:56 EDT
As of -6, no.
Comment 9 John W. Linville 2007-10-16 15:10:59 EDT
I'm going to close for now, please reopen if it is still busted when new 
updates go back into rawhide.
Comment 10 Bill Nottingham 2007-10-30 19:48:34 EDT
Reopening. I still see this with -37 and -41. However, marking as F8Target, as
this has happened in every F7 kernel as well, it's not really any *more* broken
than it was before.
Comment 12 John W. Linville 2007-10-31 09:43:58 EDT
FWIW, the "new updates" referenced in comment 9 are still not in the F8 
kernels.  The current version of them is available here:

   http://koji.fedoraproject.org/koji/taskinfo?taskID=218502

I have found them to be quite reliable on my T61.  BTW, those kernels contain 
the fixes referenced in comment 11.  Do they help you?
Comment 13 Bill Nottingham 2007-10-31 21:47:06 EDT
Using 2.6.23.1-35.wl.3.fc8, I still get occasions where it does:

wlan0: No ProbeResp from current AP 00:13:10:a6:40:59 - assume out of range
wlan0: No STA entry for own AP 00:13:10:a6:40:59
wlan0: No STA entry for own AP 00:13:10:a6:40:59

and it's then dead until I reload the module.
Comment 14 John W. Linville 2007-11-01 09:50:11 EDT
FWIW, I think that is a different problem -- I've looked into it, but not 
found a solution yet.

When you are in that situation, please try 'iwlist wlan0 scan'.  After a few 
seconds, does it reassociate?  If not, please follow-up with 'iwconfig wlan0 
essid XXXXXX' (you know what to do w/ XXXXXX).  Does that cause it to 
reassociate?

Comment 13 and this follow-up might should be a different bug...
Comment 15 Jonathan Underwood 2007-11-04 17:05:44 EST
I am having the same issue. I have installed F8-RC3 on a Dell XPS M1210 with an
iwl3945 wireless adapter. NetworkManager doesn't see any of the wireless
networks around me, and fails to connect to one when I give it an SSID. 

Running /sbin/iwlist scan gives 
wlan0     Failed to read scan data : Resource temporarily unavailable

I installed the kernels in Comment #12 and still NM doesn't see any wireless
networks or associate. However, /sbin/iwlist scan now gives
wlan0     No scan results

So, a different message, but same end result.
Comment 16 Jonathan Underwood 2007-11-04 17:08:59 EST
Also, I tried adding the disable_hw_scan=0 option to the loading of iwl3945, but
no change.
Comment 17 Jonathan Underwood 2007-11-04 18:20:54 EST
Oooh. All my problems go away when adding the option disable_hw_scan=1 to the
module options in combination with the Linville kernels in Comment #12.
Comment 18 Jonathan Underwood 2007-11-04 19:12:36 EST
I can also confirm that all issues are resolved for me using disable_hw_scan=1
with 2.6.23.1-42.fc8.
Comment 19 Bill Nottingham 2007-11-05 08:22:20 EST
(In reply to comment #14)
> FWIW, I think that is a different problem -- I've looked into it, but not 
> found a solution yet.
> 
> When you are in that situation, please try 'iwlist wlan0 scan'.  After a few 
> seconds, does it reassociate?  If not, please follow-up with 'iwconfig wlan0 
> essid XXXXXX' (you know what to do w/ XXXXXX).  Does that cause it to 
> reassociate?

Didn't seem to help. However, I'm using WPA, so that does complicate things.
Comment 20 Bill Nottingham 2007-11-07 11:25:12 EST
OK, using disable_hw_scan=1, it still randomly disconnects; however, it will
actually reconnect without reloading the module. So that's an improvement.
Comment 21 John W. Linville 2007-11-09 14:44:54 EST
Please try these kernels:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=23734

Do they work better for you?
Comment 22 Erik Pedersen 2008-01-06 13:28:35 EST
Just installed fedora 8 on a Lenovo T61, choosing to install both gnome and kde.
Wireless worked just fine, but after a yum update I cannot make it work any
more, just like described above. Have tried everything above
Comment 23 John W. Linville 2008-01-06 21:31:25 EST
What kernel are you using?  FWIW, current F8 kernels work just fine on my T61.
Comment 24 Erik Pedersen 2008-01-07 02:13:46 EST
2.6.23.9-85.fc8, and I have added 
options iwl3945 disable_hw_scan=1
to modprobe.conf

It is erratic, it just worked fine a whole evening without me knowing what 
made it work, but now it stopped working again. I tried to turn it off and on  
using the NetworkManager. I succeeded in turning it off, but now I cannot turn 
it on again
Comment 25 Erik Pedersen 2008-01-07 02:39:16 EST
Just rebooted to 2.6.23.1-42.gc8, and now it works again. I have no idea what 
is going on, totally erratic. fwiw the asus eee pc standing next to it 
connects with no problems, so there is nothing wrong with thw wireless network
Comment 26 Rui Matos 2008-01-07 05:30:58 EST
For me it's not so erratic. I just found a couple of steps that always work.
I'll describe:

I have a Dell Latitude D630 with a

0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)

running kernel-2.6.23.9-85.fc8.x86_64.

Trying to use NM to connect to the university network is asking for trouble as
it keeps disassociating and asking for the network's configurations all the time.

I can get a more stable connection using wpa_supplicant and dhclient
directly (after disabling NM) with this config:

network={
       ssid="eduroam"
       key_mgmt=WPA-EAP
       eap=PEAP
       identity=<my_user_name>
       password=<my_passwd>
       phase2="auth=MSCHAPV2"
}

but still from time to time the wlan0 interface gets into the NO_CARRIER state.

I found that the first time (after reboot) that I try to connect it will go into
NO_CARRIER. If I then kill wpa_supplicant and dhclient and quickly put them
running again I can get a lasting connection. Nothing of this is needed at home
on a WEP network where NM works fine.

It seems plenty of people were having trouble with both the 3945 and 4945
hardware, even on windows, to the point that the univ.'s network admins asked
that everyone with said hardware downloaded the latest drivers from intel's website.
Comment 27 John W. Linville 2008-01-07 15:08:22 EST
Please try the kernels here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=30116

Do these work any better or differently?
Comment 28 Erik Pedersen 2008-01-07 17:24:33 EST
Well so far it does indeed seem to work better. I turned off wireless, and I 
could turn it back on, so yes indeed, so far I say because it has been so 
erratic
Comment 29 Erik Pedersen 2008-01-08 02:06:53 EST
Ok  kernel-2.6.23.12-101.fc8.i686.rpm so far seems to work for me, thanks. I 
will get back if I run into poroblems, but it has been perfect so far
Comment 30 John W. Linville 2008-01-24 15:19:15 EST
I'm going to close this on the basis of comment 29...
Comment 31 joel jaeggli 2008-04-16 21:49:25 EDT
I continue to experience this all the way out in 2.6.24.4-64

The only thing I can characterize the experience of it as homicidal rage because
you never quite know if your ap is broken or your wireless chipset...

disabling hardware scan does work but still it sure as heck isn't fixed... 

this is a thinkpad t6op 2008cto model with intel 3945

Note You need to log in before you can comment on or make changes to this bug.