Bug 319101 - XScreenSaver.ad uses latin-1 encoding (XScreenSaver.ad.tail too)
XScreenSaver.ad uses latin-1 encoding (XScreenSaver.ad.tail too)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 15:16 EDT by Doncho N. Gunchev
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 5.03-10.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 11:02:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2007-10-04 15:16:28 EDT
Description of problem:
XScreenSaver.ad and XScreenSaver.ad.tail use latin-1 encoding - look 
for 'Copyright . 1991-2006 by', where the dot is latin1 © /(c), the copyright 
sign, in case bugzilla encodings get wrong again/.

Version-Release number of selected component (if applicable):
xscreensaver-base-5.03-9.fc8, I'm filling against xscreensaver because there's 
no xscreensaver-base.

How reproducible:
always

Steps to Reproduce:
1. install xscreensaver-base-5.03-9.fc8
2. cd /etc/xscreensaver
3. grep -R Copyright .

Actual results:
one needs iconv:
grep -R Copyright . | iconv -f latin1

./XScreenSaver.ad.tail:*splash.body.label:              Copyright © 1991-2006 
by
./XScreenSaver.ad:*splash.body.label:           Copyright © 1991-2006 by

to see this correctly

Expected results:
should not need iconv

Additional info:
Same is true for /usr/bin/xscreensaver-text, xscreensaver-getimage-video and 
xscreensaver-getimage-file, but there's some code that looks using that 
encoding plus some hacks and I can't tell what would it take to convert them 
to UTF-8.
All man pages look OK, © is in UTF-8.
Comment 1 Mamoru TASAKA 2007-10-05 00:30:19 EDT
Currently marking as NOTABUG.

* XScreenSaver.ad is really a configuration file, and 
  *splash.body.label string is used in xscreensaver-demo splash
   dialog.
Comment 2 Doncho N. Gunchev 2007-10-05 02:05:30 EDT
Excuse my curiosity, but what does "currently marking as" mean? Can bugzilla 
reopen bugs by itself? I don't really care if this never gets fixed, I'm just 
curious :-)
Comment 3 Mamoru TASAKA 2007-10-05 02:15:41 EDT
That is:

Current XScreenSaver.ad works, and I am not sure this file
can be converted into UTF-8 with no problem (this is not just
a document). It may require some investigation, so I wrote
"for now" I close as NOTABUG.
Comment 4 Mamoru TASAKA 2007-10-06 10:47:52 EDT
Will be fixed in 5.03-10.fc{7,8} (with other bugs)
Comment 5 Fedora Update System 2007-10-08 11:02:37 EDT
xscreensaver-5.03-10.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.