Bug 319331 - yum list truncates channel names making them mostly useless
yum list truncates channel names making them mostly useless
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 17:31 EDT by John T. Rose
Modified: 2009-01-20 16:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:44:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John T. Rose 2007-10-04 17:31:22 EDT
Description of problem:

yum list returns output similar to the following:

zsh-html.i386                            4.2.6-1                rhel-i386-server

The channel this and most packages comes from is truncated in the output. It
could be from rhel-i386-server-5, rhel-i386-server-fastrack-5,
rhel-i386-server-supplementary-5, rhel-i386-server-vt-5, or perhaps any number
of other channels that share the common truncated prefix rhel-i386-server.

This is not useful and worse is very confusing to users.

Version-Release number of selected component (if applicable):

yum-3.0.1-5.el5

How reproducible:

always

Steps to Reproduce:
1. open a terminal (doesn't matter if 80 columns wide or more)
2. subscribe to multiple channels sharing a common rhel5 channel prefix
3. yum list
  
Actual results:

as above

Expected results:

something that actually indicates which channel a package is from

Additional info:
Comment 1 Jan Hutař 2008-01-14 04:28:45 EST
Bug 228423 is almost duplicate of this.
Comment 2 James Antill 2008-09-26 17:09:39 EDT
Add a BZ that's already fixed, just an accounting thing.
Comment 9 errata-xmlrpc 2009-01-20 16:44:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0176.html

Note You need to log in before you can comment on or make changes to this bug.