Bug 31936 - Installer hangs when loading aic7xxx module
Installer hangs when loading aic7xxx module
Status: CLOSED DUPLICATE of bug 29555
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-15 21:15 EST by John Messina
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 00:05:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Messina 2001-03-15 21:15:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; AT&T CSM6.0)


Under both Fisher and Wolverine the installer crashes (hangs) after 
loading the aic7xxx module. This is true under graphics, text, lowres, and 
noframe modes.

Reproducible: Always
Steps to Reproduce:
1. Reboot with CD-ROM
2. attempt to boot in various modes (graphical, text, lowres, noframe)
3. loads aic7xxx module and hangs
	

Actual Results:  System hangs after attempting to load the aic7xxx module

Expected Results:  Installation should proceed to the next step.

System configuration:
Pentium 133 MHz Iwill P55VT Motherboard
AHA-2940U SCSI controller (on motherboard): 2x 1GB hard drives (sda, sdb), 
cd-rom (scd)
3Com 3C590 ethernet card 
Zoom ISA Fax/Modem
32 Meg Ram
Matrix Millenium Graphics Card - 4 meg.

Messages from VT3:
no pcic controller found
probing busses
finished bus probing
found suggestion of 3c59x
found 3c59x device
found suggestion of aic7xxx
found aic7xxx device
found devices justProbe is 0
going to insmod 3c59x.o (path is NULL)
going to insmod aic7xxx.o (path is NULL)
trying to mount device scd0
loopfd is 9
getting ready to spawn shell now
probing busses
finished bus probing
found suggestion of 3c59x
found 3c59x device
found suggestion of aic7xxx
found aic7xxx device
found devices justProbe is 0
going to insmod raid0.o (path is NULL)

Messages from VT4:
===> THESE MESSAGES REPEAT INFINITELY <===
<4> SCSI host 0 channel 0 reset (pid 0) timed out - trying harder
<4> SCSI bus is being reset for host 0 channel 0
<4> SCSI host 0 abort (pid 0) timed out - resetting
<4> SCSI bus is being reset for host 0 channel 0
===> THESE MESSAGES REPEAT INFINITELY <===
Comment 1 Michael Fulbright 2001-03-16 09:20:13 EST
Looks like a kernel module issue, reassigning.
Comment 2 Arjan van de Ven 2001-04-07 19:56:51 EDT
Doug, has this been dealt with in any of your driver updates?
Comment 3 Need Real Name 2001-04-23 23:43:21 EDT
aic7xxx  hangs when booting on SGI 1200 with  Adaptec AIC-7896/7 (rev 0) SCSI controller, 1 or 2 18Gb drives.
Comment 4 Need Real Name 2001-04-24 00:05:32 EDT
L440GX+ from Gateway 7210. Had issue with 7.1 Just booted the box
(all cards out, save Voodoo3) and the mobo AIC7896 U2 controller and 
2X IBM u2 disks and 1 Seagate U2 Disk. 

Recipe:

2.4.3 pristine + Justin Gibbs Patch 6.1.11 + patch-ac13

No new Firmware, not the old Aic7xxx. Defaults in numerical fields.

First time its booted properly. Want the kernel? can post on ftp 
server if you'd like. Big question is how can I have a normal install 
with my (3) RedHat 7.1 distros for my Sister and Brother's boxes!
Can I dissect bootnet.img? Slide in the new module or kernel?
Comment 5 Doug Ledford 2001-04-24 12:01:44 EDT
This is the same problem as 29555, marking this as a dup.  The bug is in IRQ
routing bug BTW.  If you take your pristine kernel and disable UP-IOAPIC support
and disable SMP support, it should start failing again.

*** This bug has been marked as a duplicate of 29555 ***

Note You need to log in before you can comment on or make changes to this bug.