Bug 319741 - ACPI F7 udev bug
ACPI F7 udev bug
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-04 23:29 EDT by Damien Schoof
Modified: 2008-03-05 07:04 EST (History)
1 user (show)

See Also:
Fixed In Version: 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-05 07:04:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Damien Schoof 2007-10-04 23:29:27 EDT
Description of problem:
Booting kernel with acpi on makes it hang when loading udev.  This problem did 
not occur when I was using Fedora Core 6, but when I upgraded to F7, it did 
occur - I had to disable acpi when I upgraded, and haven't been able to get it 
working since.  I am not sure if the bug is in the udev, or if it is in the 
kernel, however, I was using kernel 2.6.22 on fc6 and I did not have this 

Version-Release number of selected component (if applicable):
All released for fedora 7 so far.

How reproducible:
Booting kernel with kops: irqpoll noapic nlapic
on an AMD Turion processor (my smolt profile link is (only the kernel version 
and the fedora version are incorrect):
I have also posted a lot of info here: 

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Chuck Ebbert 2007-10-05 19:14:47 EDT
Try booting with these options:

  pci=nomsi,nommconf highres=off nohz=off

That is the default in the Fedora 6 2.6.22 kernel.
Comment 2 Damien Schoof 2007-10-10 10:02:27 EDT
(In reply to comment #1)
> Try booting with these options:
>   pci=nomsi,nommconf highres=off nohz=off
> That is the default in the Fedora 6 2.6.22 kernel.

Tried this and it booted fine. But now the hal daemon doesn't work any more - 
it just doesn't mount any devices when I plug them in, and when I manually 
mount a device from the command line, it is writable only be root.  I haven't 
found any error messages from the HAL daemon, but when I shutdown it says that 
the shutdown of the HAL daemon failed.  Also, I now can't see the battery life 
left on my laptop - the icon in the notification area has disappeared.
Comment 3 Chuck Ebbert 2007-10-10 19:26:20 EDT
Try removing one option at a time.

Also see:

Comment 4 Christopher Brown 2008-01-14 13:31:49 EST

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.


I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 5 Damien Schoof 2008-01-16 16:07:22 EST
I am sorry, I don't use F7 anymore, because I just couldn't seem to find any way
to get it working.  The strange thing is that I needed all those kernel
arguments just to get ACPI working, but now I have rolled back to FC6 and I
don't have any kernel arguments at all!  I do not want to reinstall F7, because
this is the only computer I have and I rely on it for all my work, so I prefer
to leave it in a working state.  However, it is interesting that Fedora is the
only distro (apart from openSuse) that actually works on this laptop - Ubuntu
and every other distro that I have tried to run as live CD's just keep crashing
while they are still booting.  The BIOS on this laptop is a locked version of
the Phoenix BIOS, so I can't even get in there and change any settings to make
sure that it all works good.  Sorry for the lack of information :(
Comment 6 Christopher Brown 2008-01-16 17:40:05 EST
No problem. Have you tried Fedora 8?
Comment 7 Damien Schoof 2008-01-17 15:57:35 EST
Sorry, haven't got it yet (should be getting it on DVD soon) but I am a bit
hesitant to try it, since if it goes wrong again, I will have to reinstall FC6
and then start _slowly_ upgrading all my packages again (I don't have a very
fast internet connection, so it does take a very long time to download and
upgrade all those packages :( ).
Comment 8 Christopher Brown 2008-01-17 23:16:06 EST
You may wish to consider obtaining updated spins from the fedora unity project:


as these contain the updates after the release comes out. I'll set this back to
NEEDINFO until you get a chance to test F8.
Comment 9 Christopher Brown 2008-02-15 21:45:14 EST
Any update on this?
Comment 10 Damien Schoof 2008-02-15 22:54:20 EST
Sorry, but I haven't really touched my system much - maybe close this bug down?
I don't really want to touch my system and risk stuffing the whole lot up all
over again - FC6 works and does everything that I need it to do. Can you maybe
give me an idea of how long it is supported for? That way I can update before
the repositories stop being updated, and then if I still have problems I can
just post another bug up here. I have also looked at just updating to a new
release by Yum, but since this isn't really supported I don't think that I will
do that.
Thanks for your helpful support, anyway.
Comment 11 Damien Schoof 2008-03-05 07:04:21 EST
I have done the upgrade to Fedora 8 and this bug is no longer present.
I have had no problems with ACPI, so can you now close this bug down please?
Thank you for your time and help.

Note You need to log in before you can comment on or make changes to this bug.