Bug 31977 - Crashs on start with bind and caching-nameserver loaded
Summary: Crashs on start with bind and caching-nameserver loaded
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apacheconf   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-16 12:49 UTC by Anthony Rumble
Modified: 2007-04-18 16:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-18 11:40:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anthony Rumble 2001-03-16 12:49:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-0.1.9 i686; en-US; 0.7)
Gecko/20010203


bindconf crashed with a bog standard install with bind and caching-nameserver

Reproducible: Always
Steps to Reproduce:
1.Install bind, bindconf and caching-nameserver RPM's
2.Run bindconf
3.Crash!
	

Actual Results:  Crashed out with python traceback

[root@localhost /etc]# bindconf
Traceback (innermost last):
  File "/usr/sbin/bindconf-gui", line 951, in ?
    main ()
  File "/usr/sbin/bindconf-gui", line 946, in main
    gtk.mainloop()
  File "/usr/sbin/bindconf-gui", line 777, in setup_main_tree
    zone = zlist.getMForwardZone(i)
  File "/usr/share/bindconf/dnsdata_base.py", line 1559, in getMForwardZone
    return dnsdata.MForwardZone(self.__list.getChildByIndex(pos), self)
  File "/usr/share/bindconf/dnsdata.py", line 460, in __init__
    MForwardZone_base.__init__(self, list, parent)		
  File "/usr/share/bindconf/dnsdata_base.py", line 1389, in __init__
    self.__SOA = dnsdata.SOA(child, self)
  File "/usr/share/bindconf/dnsdata.py", line 125, in __init__
    if not self.getContact(): self.setContact("root")
  File "/usr/share/bindconf/dnsdata.py", line 186, in getContact
    l = len(value)
TypeError: len() of unsized object

Comment 1 Glen Foster 2001-03-16 21:40:09 UTC
We (Red Hat) should really try to fix this before next release.

Comment 2 Harald Hoyer 2001-03-19 15:37:48 UTC
fixed since bindconf-1.0



Note You need to log in before you can comment on or make changes to this bug.