Bug 31983 - AA crashes KDE
AA crashes KDE
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-16 09:38 EST by Sammy
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-19 12:38:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2001-03-16 09:38:57 EST
Am I the only person having problems with anti-aliasing? I have the
latest rawhide installed (XFree86-4.0.2-12.1, KDE-2.1-7, qt-2.3.0).
When I turn antialiasing on KDE core dumps.

Furthermore, I tested this with running xinit and starting kde with
startkde from a xterm window (no manager). If I set QT_XFT=true
startkde core dumps...if QT_XFT=false it works. I followed all the
instructions to make sure AA is available. RENDER extension is loaded
and shows with xdpyinfo. Graphics cards are:

1. r128 on DELL Inspiron 4000
2. GeForce 256 (32MB) on a DELL Dimension XPS T750r (nv driver)

Again, I am not sure whether this is KDE or X problem. If I switch to
NVIDIA's latest drivers that support rendering same problem happens.

By the way, I have seen some people talk about xterm -fa arial.
What is the -fa option. What I know is -fn. BUT xterm -fa arial
core dumps on both of my computers!!
Comment 1 Mike A. Harris 2001-03-16 09:49:27 EST
This is an XFree86 problem that has been (hopefully) solved in the latest
build available at:

ftp://people.redhat.com/mharris

Make sure you pick up the Mesa package while you are there as it is also
required.  Also, I should note that Red Hat does not support configurations
that are using external drivers such as those available from Nvidia and
Matrox.  The latest open source Nvidia driver included with XFree86 fixes
many problems and may suit your needs.  It is included in the above release.
Comment 2 Sammy 2001-03-17 13:43:40 EST
Thanks but I can never access ftp://people.redhat.com/ accounts. Netscape
always sais there is a network problem. When I tried to access it manually
I can log in but as soon as I issue a command like ls it sais passive use
is disabled, or something like that.

One thing with KDE (rawhide), kbuildsycoca is not producing any output.
My ksycoca's were dated to Feb.26. If this file is not updated kde panel
and others start crashing intermittently.

The AA seems to be very sensitive to fonts. I had a large set of Type1
and TrueType fonts. I cannot pin point exactly where the problem is but
Type1 seems to be more of the problem. When I moved most of my Type1 fonts
to another directory things stopped core dumping (xterm, kde). I still have
some problems but hopefully they will be fixed with the new rpms and
new ksycoca.

Thanks
Comment 3 Mike A. Harris 2001-03-17 16:02:59 EST
The reason you cannot access people.redhat.com via ftp is because you are
behind either an ip filter or proxy firewall that is not allowing you
outside properly.  This is a problem you will have to work out with
your sysadmin.. sorry..

The new stuff should work for you if you can find a way to get past your
firewall.
Comment 4 Sammy 2001-03-19 12:37:56 EST
Finally got 4.0.3-1 and Mesa....this problem seems to be resolved.
Thanks

Note You need to log in before you can comment on or make changes to this bug.