Bug 31988 - Missing entries in autoconf.h
Summary: Missing entries in autoconf.h
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-16 15:15 UTC by Stefan Sorensen
Modified: 2015-01-04 22:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 01:51:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stefan Sorensen 2001-03-16 15:15:01 UTC
A lot of entries (like all the CONFIG_SOUND*) are missing from
the /usr/include/linux/autoconf.h and
/usr/src/linux/include/linux/autoconf.h files.

The problem is present in kernel-2.4.2-0.1.25, but not in the wolverine
package.

Comment 1 Arjan van de Ven 2001-03-16 16:11:41 UTC
What do you need /usr/include/linux/autoconf.h for ?

Comment 2 Stefan Sorensen 2001-03-16 16:32:16 UTC
/usr/include/linux/autoconf.h isn't really a problem, but
/usr/src/linux/include/linux/autoconf.h is needed when building drivers 
external to the kernel tree (like ALSA).



Comment 3 Joseph Kain 2001-04-03 00:46:01 UTC
Other missing entries include AGPGART_MODULE and PROC_FS which are used by
Nvidia's kernel module (and other's I'm usre).

Comment 4 Arjan van de Ven 2001-04-03 13:20:50 UTC
Missing from where? /usr/include ?
The kernel the NVidia drivers for Red Hat Linux 7.1 were built against ?


Comment 5 Joseph Kain 2001-04-03 18:36:44 UTC
There are entires missing from
  /lib/modules/.../build/include/autoconf.h
which is a symlink back to the kernel sources in /usr/src


Note You need to log in before you can comment on or make changes to this bug.