This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 3199 - aic7xxx recompile problem
aic7xxx recompile problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-01 17:07 EDT by joel
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-31 13:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description joel 1999-06-01 17:07:17 EDT
Hi -

I am using RedHat 6.0 on a Dell 4300/400 dual
pentium II setup with raid 5 ...

I needed to recompile the kernal because of the Tripp
Unison UPS ... Powersmart software ...

I am using SMP .... I tried using the aic7xxx that came
with 6.0 ... had the same error ... so I upgaded to .16
version .... and still get the following error ...
when I boot ....
      lib/aic7xxx.o
      unresolved symbol __global_sti

I did solve a different problem by uploading the new AMI
driver ... because the one that comes with 6.0 is bad ..

- Joel

------- Additional Comments From   06/09/99 07:16 -------
Was the initrd image remade after the new kernel was compiled and
installed and was lilo rerun after both the new kernel were installed
and the new initrd image had been made.  This sounds suspiciously like
the module in the initrd image is out of date with respect to the
kernel.

------- Email Received From  "Joel Weinfeld" <joel@tekdata.com> 06/14/99 11:12 -------


------- Email Received From  "Joel Weinfeld" <joel@tekdata.com> 06/14/99 13:19 -------
Comment 1 Doug Ledford 1999-06-15 01:03:59 EDT
Try disabling module versions in the kernel you are compiling, redo
the kernel, modules, initrd, and lilo steps and then see if that makes
a difference.

------- Email Received From  "Joel Weinfeld" <joel@tekdata.com> 06/15/99 16:02 -------
Comment 2 Doug Ledford 1999-06-15 16:13:59 EDT
When you remade the kernel it should have made both new AMI MegaRAID
driver and aic7xxx driver modules.  Those should have been both made
without symbol versions and they should have both loaded fine.  If
there is a problem now with the megaraid driver, then it would lead me
to suspect that the initrd is not getting remade properly (again).
Keep in mind that if there is an initrd image already in existence,
mkinitrd will not overwrite that image without the -f flag.  I would
suggest you use the -f -v flags to mkinitrd to verify that the new
initrd is made properly and that you also make sure that the modules
being placed on the new initrd image are from the fresh kernel/module
compile and that none of them are "leftovers" so to speak.

------- Email Received From  "Joel Weinfeld" <joel@tekdata.com> 06/25/99 11:36 -------


------- Email Received From  "Joel Weinfeld" <joel@tekdata.com> 06/25/99 15:27 -------

Note You need to log in before you can comment on or make changes to this bug.